aboutsummaryrefslogtreecommitdiffstats
path: root/audio/amarok
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2006-09-15 18:11:50 +0800
committermich <mich@FreeBSD.org>2006-09-15 18:11:50 +0800
commitc057c4a7778b8d6d9a7ec40137e48b6d2d6be616 (patch)
treed450ff5c6e9420eba402d866b333a3da097e3f14 /audio/amarok
parentb275ff1a2a08f61ee07aa6f4d7f89efdd9cfd72c (diff)
downloadfreebsd-ports-gnome-c057c4a7778b8d6d9a7ec40137e48b6d2d6be616.tar.gz
freebsd-ports-gnome-c057c4a7778b8d6d9a7ec40137e48b6d2d6be616.tar.zst
freebsd-ports-gnome-c057c4a7778b8d6d9a7ec40137e48b6d2d6be616.zip
- Fix playlist encoding problem. This bug could also result in failure
to restore the current playlist. - Bump PORTREVISION Obtained from: Amarok dev team
Diffstat (limited to 'audio/amarok')
-rw-r--r--audio/amarok/Makefile1
-rw-r--r--audio/amarok/files/patch-amarok_src_playlist.cpp13
2 files changed, 14 insertions, 0 deletions
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index 422e9fcb49c5..c6a8f241448b 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -6,6 +6,7 @@
PORTNAME= amarok
PORTVERSION= 1.4.3
+PORTREVISION= 1
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
diff --git a/audio/amarok/files/patch-amarok_src_playlist.cpp b/audio/amarok/files/patch-amarok_src_playlist.cpp
new file mode 100644
index 000000000000..eb1139a37507
--- /dev/null
+++ b/audio/amarok/files/patch-amarok_src_playlist.cpp
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- amarok/src/playlist.cpp.orig
++++ amarok/src/playlist.cpp
+@@ -3168,6 +3168,7 @@
+ stream << "</playlist>\n";
+
+ QTextStream fstream( &file );
++ fstream.setEncoding( QTextStream::UnicodeUTF8 );
+ fstream << buffer;
+ }
+