aboutsummaryrefslogtreecommitdiffstats
path: root/audio/amarok
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2004-12-01 06:40:26 +0800
committerkwm <kwm@FreeBSD.org>2004-12-01 06:40:26 +0800
commita5e6e7902deeca845cbab1d12f23b0fd5264cbda (patch)
tree02d3e23c3a34de2bc3ea628a599fcbda06197bdf /audio/amarok
parentf2ef79c89ea10f9c1b2c61510e8771c96922f0f8 (diff)
downloadfreebsd-ports-gnome-a5e6e7902deeca845cbab1d12f23b0fd5264cbda.tar.gz
freebsd-ports-gnome-a5e6e7902deeca845cbab1d12f23b0fd5264cbda.tar.zst
freebsd-ports-gnome-a5e6e7902deeca845cbab1d12f23b0fd5264cbda.zip
Add libvisual support to amarok.
Approved by: pav (mentor), markus (maintainer)
Diffstat (limited to 'audio/amarok')
-rw-r--r--audio/amarok/Makefile20
-rw-r--r--audio/amarok/files/patch-amarok-src-vis-libvisual-libvisual.cpp16
-rw-r--r--audio/amarok/pkg-plist1
3 files changed, 37 insertions, 0 deletions
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index c59a77a412c0..224400692506 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -16,6 +16,8 @@ COMMENT= Media player for KDE
LIB_DEPENDS= tag.4:${PORTSDIR}/audio/taglib
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-configure
+
USE_BZIP2= yes
USE_KDELIBS_VER=3
USE_GMAKE= yes
@@ -26,6 +28,7 @@ OPTIONS= ARTS "aRts support" off \
GSTREAMER "GStreamer support" on \
XINE "xine support" off \
XMMS "XMMS visualizations" on \
+ LIBVISUAL "libvisual support" on \
OPENGL "OpenGL support" on \
AMAZON "Amazon cover fetching support" on
@@ -63,6 +66,14 @@ LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
PLIST_SUB+= XMMS=""
.endif
+.if defined(WITHOUT_LIBVISUAL)
+PLIST_SUB+= LIBVISUAL="@comment "
+.else
+LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
+PLIST_SUB+= LIBVISUAL=""
+
+.endif
+
.if defined(WITHOUT_OPENGL)
CONFIGURE_ARGS+=--without-opengl
.endif
@@ -74,11 +85,20 @@ CONFIGURE_ARGS+=--without-amazon
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's|xx||g' ${WRKSRC}/po/Makefile.in
+ @${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL11/SDL.h|g' \
+ ${WRKSRC}/amarok/src/vis/libvisual/libvisual.h
+ @${REINPLACE_CMD} -e 's|-lSDL|-lSDL-1.1 ${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/amarok/src/vis/libvisual/Makefile.in
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${TOUCH}
post-configure:
.if defined(WITHOUT_XMMS)
@${REINPLACE_CMD} -e '/XMMS /d' ${WRKSRC}/config.h
@${REINPLACE_CMD} -e 's/xmmswrapper//g' ${WRKSRC}/amarok/src/vis/Makefile
.endif
+.if defined(WITHOUT_LIBVISUAL)
+ @${REINPLACE_CMD} -e '/LIBVISUAL /d' ${WRKSRC}/config.h
+ @${REINPLACE_CMD} -e 's/libvisual//g' ${WRKSRC}/amarok/src/vis/Makefile
+.endif
.include <bsd.port.post.mk>
diff --git a/audio/amarok/files/patch-amarok-src-vis-libvisual-libvisual.cpp b/audio/amarok/files/patch-amarok-src-vis-libvisual-libvisual.cpp
new file mode 100644
index 000000000000..9519f6aa7a1f
--- /dev/null
+++ b/audio/amarok/files/patch-amarok-src-vis-libvisual-libvisual.cpp
@@ -0,0 +1,16 @@
+--- amarok/src/vis/libvisual/libvisual.cpp.orig Sun Nov 28 16:51:39 2004
++++ amarok/src/vis/libvisual/libvisual.cpp Sun Nov 28 16:52:56 2004
+@@ -267,11 +267,11 @@
+ break;
+
+ case SDL_MOUSEBUTTONDOWN:
+- visual_event_queue_add_mousebutton (vevent, event.button.button, VISUAL_MOUSE_DOWN);
++ visual_event_queue_add_mousebutton (vevent, event.button.button, VISUAL_MOUSE_DOWN, 0, 0);
+ break;
+
+ case SDL_MOUSEBUTTONUP:
+- visual_event_queue_add_mousebutton (vevent, event.button.button, VISUAL_MOUSE_UP);
++ visual_event_queue_add_mousebutton (vevent, event.button.button, VISUAL_MOUSE_UP, 0, 0);
+ break;
+
+ case SDL_QUIT:
diff --git a/audio/amarok/pkg-plist b/audio/amarok/pkg-plist
index 6e12e39802b6..68a1fcaaf8ef 100644
--- a/audio/amarok/pkg-plist
+++ b/audio/amarok/pkg-plist
@@ -1,4 +1,5 @@
bin/amarok
+%%LIBVISUAL%%bin/amarok_libvisual
%%XMMS%%bin/amarok_xmmswrapper2
bin/amarokapp
bin/release_amarok