aboutsummaryrefslogtreecommitdiffstats
path: root/audio/aube/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-06-10 17:26:34 +0800
committerfjoe <fjoe@FreeBSD.org>2003-06-10 17:26:34 +0800
commit74e053a103324cf2115ddcaf47b46731ec85fa78 (patch)
treea8ef1d516c8321511c9f40977c69a6077689825f /audio/aube/Makefile
parent54c161be56c0a89597744cb730d04678d0235e44 (diff)
downloadfreebsd-ports-gnome-74e053a103324cf2115ddcaf47b46731ec85fa78.tar.gz
freebsd-ports-gnome-74e053a103324cf2115ddcaf47b46731ec85fa78.tar.zst
freebsd-ports-gnome-74e053a103324cf2115ddcaf47b46731ec85fa78.zip
New port: audio/aube
System for sound generation and processing PR: 53125 Submitted by: Kirill Ponomarew
Diffstat (limited to 'audio/aube/Makefile')
-rw-r--r--audio/aube/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/aube/Makefile b/audio/aube/Makefile
new file mode 100644
index 000000000000..b72ea6c1d5bf
--- /dev/null
+++ b/audio/aube/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: aube
+# Date created: 09.06.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aube
+PORTVERSION= 0.30.2
+CATEGORIES= audio gnome
+MASTER_SITES= http://www.metadecks.org/software/aube/download/
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= System for sound generation and processing
+
+LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomeprefix gnomehier gnomehack gtk12 imlib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= aube.1
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>