aboutsummaryrefslogtreecommitdiffstats
path: root/audio/aubio/Makefile
diff options
context:
space:
mode:
authortrasz <trasz@FreeBSD.org>2008-08-25 02:04:07 +0800
committertrasz <trasz@FreeBSD.org>2008-08-25 02:04:07 +0800
commitac0a3a1e2bdffa70a0a36fbfd014bb725930911e (patch)
tree6ae139b31b4734e41c53720df76158557d18871e /audio/aubio/Makefile
parent69079a0c5a43654c019672475911108584a4b32d (diff)
downloadfreebsd-ports-gnome-ac0a3a1e2bdffa70a0a36fbfd014bb725930911e.tar.gz
freebsd-ports-gnome-ac0a3a1e2bdffa70a0a36fbfd014bb725930911e.tar.zst
freebsd-ports-gnome-ac0a3a1e2bdffa70a0a36fbfd014bb725930911e.zip
aubio is a library for audio labelling. Its features include
segmenting a sound file before each of its attacks, performing pitch detection, tapping the beat and producing midi streams from live audio. The name aubio comes from 'audio' with a typo: several transcription errors are likely to be found in the results too. The aim of this project is to provide these automatic labelling features to other audio softwares. Functions can be used offline in sound editors and software samplers, or online in audio effects and virtual instruments. WWW: http://aubio.org/
Diffstat (limited to 'audio/aubio/Makefile')
-rw-r--r--audio/aubio/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/aubio/Makefile b/audio/aubio/Makefile
new file mode 100644
index 000000000000..aad878c3cd69
--- /dev/null
+++ b/audio/aubio/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: aubio
+# Date created: 2008-07-21
+# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aubio
+PORTVERSION= 0.3.2
+CATEGORIES= audio
+MASTER_SITES= http://aubio.org/pub/
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= Library for audio labelling
+
+LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ jack.0:${PORTSDIR}/audio/jack \
+ fftw3f:${PORTSDIR}/math/fftw3-float \
+ lash.2:${PORTSDIR}/audio/lash
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+# --disable-complex, because it won't compile otherwise
+# due to missing carg(3) et al.
+CONFIGURE_ARGS= "CFLAGS=${CFLAGS} -I${LOCALBASE}/include" --disable-complex
+
+.include <bsd.port.mk>