aboutsummaryrefslogtreecommitdiffstats
path: root/audio/audacity
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-03-24 04:42:41 +0800
committerriggs <riggs@FreeBSD.org>2016-03-24 04:42:41 +0800
commit3ffcf4489e5c723386fc18899364b40f421c4ffb (patch)
tree0b34976923a58bd135e3da2fc5eb53d4155c442c /audio/audacity
parentfa37120f1e4724b42d69e6e69253415b7f748668 (diff)
downloadfreebsd-ports-gnome-3ffcf4489e5c723386fc18899364b40f421c4ffb.tar.gz
freebsd-ports-gnome-3ffcf4489e5c723386fc18899364b40f421c4ffb.tar.zst
freebsd-ports-gnome-3ffcf4489e5c723386fc18899364b40f421c4ffb.zip
Fix build failure when accidentally picking up alsa (libasound).
Currently, there is no configure switch for consistently disabling alsa detection. This changeset introduces the possibility to do so during the configure stage and adds ALSA as a non-default OPTION. PR: 207892 Submitted by: tatsuki_makino@hotmail.com Reported by: bar Reviewed by: xxjack12xx@gmail.com, riggs Approved by: xxjack12xx@gmail.com (maintainer)
Diffstat (limited to 'audio/audacity')
-rw-r--r--audio/audacity/Makefile11
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqsrc_sound.h11
-rw-r--r--audio/audacity/files/patch-lib-src_portmixer_configure.ac23
-rw-r--r--audio/audacity/files/patch-lib-src_portmixer_src_px__linux__alsa.c10
-rw-r--r--audio/audacity/files/patch-src_BatchCommands.cpp11
5 files changed, 63 insertions, 3 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 9761ced96de2..f4335b78b524 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -37,8 +37,8 @@ PORTDOCS= README.txt
DOS2UNIX_GLOB= Makefile.* *.c* *.h
SHEBANG_FILES= lib-src/lv2/build
-OPTIONS_DEFINE= NLS DEBUG DOCS DYNLOAD FFMPEG FLAC ID3TAG LADSPA LAME LV2 MAD \
- SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
+OPTIONS_DEFINE= NLS DEBUG DOCS ALSA DYNLOAD FFMPEG FLAC ID3TAG LADSPA LAME LV2 \
+ MAD SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
@@ -80,6 +80,13 @@ DEBUG_CONFIGURE_WITH= debug
DOCS_BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man \
docbook2man:${PORTSDIR}/textproc/docbook-utils
+ALSA_CONFIGURE_OFF= --disable-alsa
+ALSA_CONFIGURE_WITH= alsa
+ALSA_CFLAGS= -I${LOCALBASE}/include
+ALSA_CXXFLAGS= -I${LOCALBASE}/include
+ALSA_LDFLAGS= -L${LOCALBASE}/lib
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+
DYNLOAD_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libavcodec.pc:${PORTSDIR}/multimedia/ffmpeg
DYNLOAD_BUILD_DEPENDS= ${LOCALBASE}/include/lame/lame.h:${PORTSDIR}/audio/lame
DYNLOAD_CONFIGURE_ENABLE= dynamic-loading
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqsrc_sound.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqsrc_sound.h
new file mode 100644
index 000000000000..ea13f2a06b99
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqsrc_sound.h
@@ -0,0 +1,11 @@
+--- lib-src/libnyquist/nyquist/nyqsrc/sound.h.orig 2016-01-08 22:05:48 UTC
++++ lib-src/libnyquist/nyquist/nyqsrc/sound.h
+@@ -459,7 +459,7 @@ double step_to_hz(double);
+
+ #ifdef WIN32
+ double log2(double x);
+-#endif WIN32
++#endif /*WIN32*/
+
+ /* macros for access to samples within a suspension */
+ /* NOTE: assume suspension structure is named "susp" */
diff --git a/audio/audacity/files/patch-lib-src_portmixer_configure.ac b/audio/audacity/files/patch-lib-src_portmixer_configure.ac
index b8ef52023dcb..c8c926a3c6e9 100644
--- a/audio/audacity/files/patch-lib-src_portmixer_configure.ac
+++ b/audio/audacity/files/patch-lib-src_portmixer_configure.ac
@@ -1,6 +1,16 @@
--- lib-src/portmixer/configure.ac.orig 2016-01-08 22:05:48 UTC
+++ lib-src/portmixer/configure.ac
-@@ -43,7 +43,7 @@ PKG_CHECK_MODULES([PORTAUDIO], [portaudi
+@@ -35,6 +35,9 @@ AC_ARG_ENABLE([debug],
+ [AC_SUBST( cflags, ["$cflags -g"] ) AC_MSG_RESULT(yes)],
+ [AC_SUBST( cflags, ["$cflags -O2"] ) AC_MSG_RESULT(no)])
+
++AC_ARG_ENABLE([alsa],
++ AC_HELP_STRING([--disable-alsa], []))
++
+ PKG_CHECK_MODULES([PORTAUDIO], [portaudio-2.0 >= 19])
+
+ #
+@@ -43,7 +46,7 @@ PKG_CHECK_MODULES([PORTAUDIO], [portaudi
dnl The following tests need to have the header files of portaudio available.
cppflags_save="$CPPFLAGS"
@@ -9,3 +19,14 @@
have_oss=no
AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h machine/soundcard.h], have_oss=yes)
+@@ -123,8 +126,8 @@ if [[ $have_oss = "yes" ]] ; then
+ have_support=yes
+ fi
+
+-AM_CONDITIONAL([USE_LINUX_ALSA], [test "$have_alsa" = yes])
+-if [[ $have_alsa = "yes" ]] ; then
++AM_CONDITIONAL([USE_LINUX_ALSA], [test "$have_alsa" = yes -a "x$enable_alsa" != "xno"])
++if [[ $have_alsa = "yes" -a "x$enable_alsa" != "xno" ]] ; then
+ AC_MSG_NOTICE([Including support for ALSA])
+ AC_DEFINE(PX_USE_LINUX_ALSA)
+ have_support=yes
diff --git a/audio/audacity/files/patch-lib-src_portmixer_src_px__linux__alsa.c b/audio/audacity/files/patch-lib-src_portmixer_src_px__linux__alsa.c
new file mode 100644
index 000000000000..cf697fc92b87
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src_portmixer_src_px__linux__alsa.c
@@ -0,0 +1,10 @@
+--- lib-src/portmixer/src/px_linux_alsa.c.orig 2016-01-08 22:05:48 UTC
++++ lib-src/portmixer/src/px_linux_alsa.c
+@@ -42,6 +42,7 @@
+
+ #include "portaudio.h"
+ #include "pa_unix_oss.h"
++#include <pa_linux_alsa.h>
+
+ #include "portmixer.h"
+ #include "px_mixer.h"
diff --git a/audio/audacity/files/patch-src_BatchCommands.cpp b/audio/audacity/files/patch-src_BatchCommands.cpp
new file mode 100644
index 000000000000..b83a400a9937
--- /dev/null
+++ b/audio/audacity/files/patch-src_BatchCommands.cpp
@@ -0,0 +1,11 @@
+--- src/BatchCommands.cpp.orig 2016-01-08 22:05:48 UTC
++++ src/BatchCommands.cpp
+@@ -151,7 +151,7 @@ bool BatchCommands::ReadChain(const wxSt
+ else if (cmd == wxT("ExportWav"))
+ cmd = wxT("ExportWAV");
+ else if (cmd == wxT("Compressor") && (parm.find(wxT("DecayTime")) != parm.npos))
+- parm.Replace(wxT("DecayTime"), wxT("ReleaseTime"), NULL); // 2.0.6
++ parm.Replace(wxT("DecayTime"), wxT("ReleaseTime"), false); // 2.0.6
+
+ // Add to lists
+ mCommandChain.Add(cmd);