aboutsummaryrefslogtreecommitdiffstats
path: root/audio/audex
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-19 19:09:21 +0800
committermiwi <miwi@FreeBSD.org>2009-07-19 19:09:21 +0800
commiteff979c7a9d76a8d5e3a4b1de9bce09d73992b97 (patch)
treee06a5a0f892bd19af3776d9bd3e7431a093041c3 /audio/audex
parent4b61eaa3de340ccff61908fcc7aa9d01809e8793 (diff)
downloadfreebsd-ports-gnome-eff979c7a9d76a8d5e3a4b1de9bce09d73992b97.tar.gz
freebsd-ports-gnome-eff979c7a9d76a8d5e3a4b1de9bce09d73992b97.tar.zst
freebsd-ports-gnome-eff979c7a9d76a8d5e3a4b1de9bce09d73992b97.zip
Audex is an audio CD ripping tool for KDE4.
Features include: - Extracting with CDDA Paranoia. So you have quite perfect audio quality. - Extracting and encoding run parallel. - Filename editing with local and remote CDDB/FreeDB database. - Metadata correction tools like capitalization. - Multi-profile extraction (with one commandline-encoder per profile). - Fetch covers from the internet and store them in the database. - Create playlists, cover and template-based-info files in target directory. - Creates extraction and encoding protocols. - Transfer files with KDE KIO-Slaves. WWW: http://opensource.maniatek.de/cgi-bin/audex/audex/index.html PR: ports/135436 Submitted by: Jason E. Hale <bsdkaffee at gmail.com>
Diffstat (limited to 'audio/audex')
-rw-r--r--audio/audex/Makefile52
-rw-r--r--audio/audex/distinfo3
-rw-r--r--audio/audex/files/patch-utils__encoderassistant.cpp11
-rw-r--r--audio/audex/pkg-descr14
-rw-r--r--audio/audex/pkg-plist29
5 files changed, 109 insertions, 0 deletions
diff --git a/audio/audex/Makefile b/audio/audex/Makefile
new file mode 100644
index 000000000000..9e1c885a9382
--- /dev/null
+++ b/audio/audex/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: audex
+# Date Created: 2009-05-20
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= audex
+DISTVERSION= 0.71b3
+CATEGORIES= audio kde
+MASTER_SITES= http://opensource.maniatek.de/${PORTNAME}/files/
+
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= Audio CD ripping utility for KDE4
+
+LIB_DEPENDS= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia \
+ kcddb.5:${PORTSDIR}/multimedia/kdemultimedia4
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_CMAKE= yes
+USE_KDE4= automoc4 kdeprefix kdelibs
+USE_QT_VER= 4
+QT_COMPONENTS= gui dbus network qt3support sql svg xml \
+ qmake_build moc_build rcc_build uic_build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS= FAAC "Depend on audio/faac for m4a encoding" off \
+ FLAC "Depend on audio/flac for flac encoding" on \
+ LAME "Depend on audio/lame for mp3 encoding" off \
+ OGG "Depend on audio/vorbis-tools for ogg encoding" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FAAC)
+RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
+.endif
+
+.if defined(WITH_FLAC)
+RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
+.endif
+
+.if defined(WITH_LAME)
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+.endif
+
+.if defined(WITH_OGG)
+RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/audex/distinfo b/audio/audex/distinfo
new file mode 100644
index 000000000000..2f2c5ea7a9a1
--- /dev/null
+++ b/audio/audex/distinfo
@@ -0,0 +1,3 @@
+MD5 (audex-0.71b3.tar.bz2) = 18803732dfd6e16f2bba3773940c04cd
+SHA256 (audex-0.71b3.tar.bz2) = 76ba9634bf91abd8b73ca5aa185671e2488122d3409f61fead70a347613e2139
+SIZE (audex-0.71b3.tar.bz2) = 183745
diff --git a/audio/audex/files/patch-utils__encoderassistant.cpp b/audio/audex/files/patch-utils__encoderassistant.cpp
new file mode 100644
index 000000000000..4148f9e53576
--- /dev/null
+++ b/audio/audex/files/patch-utils__encoderassistant.cpp
@@ -0,0 +1,11 @@
+--- ./utils/encoderassistant.cpp.orig 2009-06-10 05:24:03.000000000 -0400
++++ ./utils/encoderassistant.cpp 2009-06-10 05:24:41.000000000 -0400
+@@ -44,7 +44,7 @@
+ case EncoderAssistant::OGGENC : return (KProcess::execute(ENCODER_OGGENC_BIN, QStringList() << ENCODER_OGGENC_VERSION_PARA)==0);
+ case EncoderAssistant::FLAC : return (KProcess::execute(ENCODER_FLAC_BIN, QStringList() << ENCODER_FLAC_VERSION_PARA)==0);
+ case EncoderAssistant::FAAC : return (KProcess::execute(ENCODER_FAAC_BIN, QStringList() << ENCODER_FAAC_VERSION_PARA)==1);
+- case EncoderAssistant::WAVE : return (KProcess::execute(ENCODER_WAVE_BIN, QStringList() << ENCODER_WAVE_VERSION_PARA)==0);
++ case EncoderAssistant::WAVE : return TRUE;
+ case EncoderAssistant::CUSTOM : return TRUE;
+ default : return FALSE;
+
diff --git a/audio/audex/pkg-descr b/audio/audex/pkg-descr
new file mode 100644
index 000000000000..ce9cfe2e1794
--- /dev/null
+++ b/audio/audex/pkg-descr
@@ -0,0 +1,14 @@
+Audex is an audio CD ripping tool for KDE4.
+
+Features include:
+- Extracting with CDDA Paranoia. So you have quite perfect audio quality.
+- Extracting and encoding run parallel.
+- Filename editing with local and remote CDDB/FreeDB database.
+- Metadata correction tools like capitalization.
+- Multi-profile extraction (with one commandline-encoder per profile).
+- Fetch covers from the internet and store them in the database.
+- Create playlists, cover and template-based-info files in target directory.
+- Creates extraction and encoding protocols.
+- Transfer files with KDE KIO-Slaves.
+
+WWW: http://opensource.maniatek.de/cgi-bin/audex/audex/index.html
diff --git a/audio/audex/pkg-plist b/audio/audex/pkg-plist
new file mode 100644
index 000000000000..adffc846d0dd
--- /dev/null
+++ b/audio/audex/pkg-plist
@@ -0,0 +1,29 @@
+bin/audex
+share/applications/kde4/audex.desktop
+share/apps/audex/audexui.rc
+share/apps/audex/images/amazon.png
+share/apps/audex/images/canada.png
+share/apps/audex/images/france.png
+share/apps/audex/images/germany.png
+share/apps/audex/images/italy.png
+share/apps/audex/images/japan.png
+share/apps/audex/images/netherlands.png
+share/apps/audex/images/nocover.png
+share/apps/audex/images/poland.png
+share/apps/audex/images/portugal.png
+share/apps/audex/images/spain.png
+share/apps/audex/images/sweden.png
+share/apps/audex/images/uk.png
+share/apps/audex/images/usa.png
+share/apps/solid/actions/audex-rip-audiocd.desktop
+share/icons/hicolor/128x128/apps/audex.png
+share/icons/hicolor/16x16/apps/audex.png
+share/icons/hicolor/32x32/apps/audex.png
+share/icons/hicolor/48x48/apps/audex.png
+share/icons/hicolor/64x64/apps/audex.png
+share/locale/cs/LC_MESSAGES/audex.mo
+share/locale/de/LC_MESSAGES/audex.mo
+share/locale/nl/LC_MESSAGES/audex.mo
+share/locale/pt_BR/LC_MESSAGES/audex.mo
+@dirrm share/apps/audex/images
+@dirrm share/apps/audex