aboutsummaryrefslogtreecommitdiffstats
path: root/audio/audiere
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-06-23 18:10:09 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-06-23 18:10:09 +0800
commit6c74f7d9de05b1a137c59863bde927109602edd2 (patch)
treec68a00c3949d403e47b785bfe8ed5bdb74328b20 /audio/audiere
parent174a72852e3360a31ad3394d20f3d6b8dc0c11b3 (diff)
downloadfreebsd-ports-gnome-6c74f7d9de05b1a137c59863bde927109602edd2.tar.gz
freebsd-ports-gnome-6c74f7d9de05b1a137c59863bde927109602edd2.tar.zst
freebsd-ports-gnome-6c74f7d9de05b1a137c59863bde927109602edd2.zip
Audiere is a high-level audio API. It can play Ogg Vorbis, MP3,
FLAC, uncompressed WAV, AIFF, MOD, S3M, XM, and IT files. For audio output, Audiere supports DirectSound or WinMM in Windows, OSS on Linux and Cygwin, and SGI AL on IRIX. Audiere is open source and licensed under the LGPL. This means that you may freely use Audiere in commercial products, as long as you do not modify the source code. If you do modify Audiere and release a product that uses your modifications, you must release your changes to the code under the LGPL as well. Audiere is portable. It is tested on Windows, Linux-i386, Cygwin, and IRIX with at least three major compilers. Most of Audiere is endian-independent, so I expect it would work with few modifications on other architectures. WWW: http://audiere.sourceforge.net/ PR: ports/124710 Approved by: miwi (mentor)
Diffstat (limited to 'audio/audiere')
-rw-r--r--audio/audiere/Makefile86
-rw-r--r--audio/audiere/distinfo3
-rw-r--r--audio/audiere/files/patch-src-speexfile-speexfile.cpp11
-rw-r--r--audio/audiere/pkg-descr17
-rw-r--r--audio/audiere/pkg-plist6
5 files changed, 123 insertions, 0 deletions
diff --git a/audio/audiere/Makefile b/audio/audiere/Makefile
new file mode 100644
index 000000000000..a1e12a26e353
--- /dev/null
+++ b/audio/audiere/Makefile
@@ -0,0 +1,86 @@
+# New ports collection makefile for: audiere
+# Date created: 12 Sep 2007
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= audiere
+PORTVERSION= 1.9.4
+CATEGORIES= audio
+MASTER_SITES= SF
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= High-level audio API
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WANT_WX= yes
+USE_AUTOTOOLS= autoconf:261
+USE_LDCONFIG= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include/speex -I${LOCALBASE}/include" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+
+PORTDOCS= changelog.txt cvs.txt dependencies.txt faq.txt glossary.txt \
+ license.txt overview.txt readme.txt release-howto.txt \
+ tutorial.txt
+
+CONFIGURE_REPLACES='s|wx_config|no_&|'
+
+OPTIONS= DUMB "Enable DUMB support" on \
+ CDAUDIO "Enable libcdaudio support" on \
+ VORBIS "Enable ogg vorbis support" on \
+ SPEEX "Enable speex support" on
+# FLAC "Enable FLAC support" on
+
+.include <bsd.port.pre.mk>
+
+# Broken with recent FLAC
+#.if !defined(WITHOUT_FLAC)
+#LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+#.else
+CONFIGURE_REPLACES+='/AC_CHECK_LIB/ s|FLAC|no_&|'
+#.endif
+
+.if !defined(WITHOUT_DUMB)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libdumb.a:${PORTSDIR}/audio/dumb
+.else
+CONFIGURE_REPLACES+='/AC_CHECK_LIB/ s|dumb|no_&|'
+.endif
+
+.if !defined(WITHOUT_CDAUDIO)
+LIB_DEPENDS+= cdaudio.1:${PORTSDIR}/audio/libcdaudio
+.else
+CONFIGURE_REPLACES+='/AC_CHECK_LIB/ s|cdaudio|no_&|'
+.endif
+
+.if !defined(WITHOUT_VORBIS)
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis \
+ ogg.5:${PORTSDIR}/audio/libogg
+.else
+CONFIGURE_REPLACES+='/AC_CHECK_HEADER/ s|vorbis|no_&|'
+.endif
+
+.if !defined(WITHOUT_SPEEX)
+LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+.else
+CONFIGURE_REPLACES+='/AC_CHECK_HEADER/ s|speex|no_&|'
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} ${CONFIGURE_REPLACES:C/.*/-e &/} \
+ -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/configure.in
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/audiere/distinfo b/audio/audiere/distinfo
new file mode 100644
index 000000000000..8f53a6dd941f
--- /dev/null
+++ b/audio/audiere/distinfo
@@ -0,0 +1,3 @@
+MD5 (audiere-1.9.4.tar.gz) = b95dfe6f1e69cfd12371747f22772766
+SHA256 (audiere-1.9.4.tar.gz) = 74538fbc2f1ef467b3e1376c6ff4e0f40b664fca1dbfb1fcaa2fb823d5f5a219
+SIZE (audiere-1.9.4.tar.gz) = 453279
diff --git a/audio/audiere/files/patch-src-speexfile-speexfile.cpp b/audio/audiere/files/patch-src-speexfile-speexfile.cpp
new file mode 100644
index 000000000000..0f6fa13d1895
--- /dev/null
+++ b/audio/audiere/files/patch-src-speexfile-speexfile.cpp
@@ -0,0 +1,11 @@
+--- src/speexfile/speexfile.cpp.orig 2006-02-14 07:57:01.000000000 +0300
++++ src/speexfile/speexfile.cpp 2008-06-16 04:56:31.000000000 +0400
+@@ -871,7 +871,7 @@
+ void *speexfile::header_to_decoder ( SpeexHeader *header, int enh_enabled, int *frame_size, int *rate, int *nframes, int forceMode, int *channels, SpeexStereoState *stereo )
+ {
+ void *st;
+- SpeexMode *mode;
++ const SpeexMode *mode;
+ SpeexCallback callback;
+ int modeID;
+
diff --git a/audio/audiere/pkg-descr b/audio/audiere/pkg-descr
new file mode 100644
index 000000000000..6b33077b7f91
--- /dev/null
+++ b/audio/audiere/pkg-descr
@@ -0,0 +1,17 @@
+Audiere is a high-level audio API. It can play Ogg Vorbis, MP3,
+FLAC, uncompressed WAV, AIFF, MOD, S3M, XM, and IT files. For audio
+output, Audiere supports DirectSound or WinMM in Windows, OSS on
+Linux and Cygwin, and SGI AL on IRIX.
+
+Audiere is open source and licensed under the LGPL. This means that
+you may freely use Audiere in commercial products, as long as you
+do not modify the source code. If you do modify Audiere and release
+a product that uses your modifications, you must release your changes
+to the code under the LGPL as well.
+
+Audiere is portable. It is tested on Windows, Linux-i386, Cygwin,
+and IRIX with at least three major compilers. Most of Audiere is
+endian-independent, so I expect it would work with few modifications
+on other architectures.
+
+WWW: http://audiere.sourceforge.net/
diff --git a/audio/audiere/pkg-plist b/audio/audiere/pkg-plist
new file mode 100644
index 000000000000..cc743ee2235a
--- /dev/null
+++ b/audio/audiere/pkg-plist
@@ -0,0 +1,6 @@
+bin/audiere-config
+include/audiere.h
+lib/libaudiere-1.9.4.so
+lib/libaudiere.a
+lib/libaudiere.la
+lib/libaudiere.so