aboutsummaryrefslogtreecommitdiffstats
path: root/audio/aumix
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2010-07-12 22:12:24 +0800
committerwxs <wxs@FreeBSD.org>2010-07-12 22:12:24 +0800
commit5e57bbdffb441419e958e8c0c3d6e85bc4eb797b (patch)
tree3f36526aca228aa5d73fd513a5457927ebe2be08 /audio/aumix
parent161f3fa54f753bddb2bfc2afd632ce5b7611e13c (diff)
downloadfreebsd-ports-gnome-5e57bbdffb441419e958e8c0c3d6e85bc4eb797b.tar.gz
freebsd-ports-gnome-5e57bbdffb441419e958e8c0c3d6e85bc4eb797b.tar.zst
freebsd-ports-gnome-5e57bbdffb441419e958e8c0c3d6e85bc4eb797b.zip
Update to 2.9.1
Add license information Switch to OPTIONS (and general cleanup because of this) PR: ports/147922 Submitted by: Bapt <baptiste.daroussin@gmail.com> Approved by: unix4all@gulic.org (maintainer)
Diffstat (limited to 'audio/aumix')
-rw-r--r--audio/aumix/Makefile39
-rw-r--r--audio/aumix/distinfo6
-rw-r--r--audio/aumix/files/patch-src_common.c12
3 files changed, 18 insertions, 39 deletions
diff --git a/audio/aumix/Makefile b/audio/aumix/Makefile
index b74fa188c63b..dffa57c096ab 100644
--- a/audio/aumix/Makefile
+++ b/audio/aumix/Makefile
@@ -6,15 +6,18 @@
#
PORTNAME= aumix
-PORTVERSION= 2.8
-PORTREVISION= 7
+PORTVERSION= 2.9.1
CATEGORIES= audio
MASTER_SITES= SF \
http://jpj.net/~trevor/aumix/ \
http://jpj.net/~trevor/aumix/old/
+
MAINTAINER= unix4all@gulic.org
COMMENT= Audio mixer for X11, terminal, or command line
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_BZIP2= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -24,47 +27,35 @@ CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= aumix.1 xaumix.1
+MAN1= aumix.1 xaumix.1 mute.1
PLIST_DIRS= share/aumix
PLIST_FILES= bin/aumix bin/mute bin/xaumix
.for ii in ansi aumix.xpm fadein.set fadeout.set vt100 xterm
PLIST_FILES+= share/aumix/${ii}
.endfor
-.if defined(WITHOUT_NLS) || defined(WITHOUT_ALL)
+OPTIONS= NLS "Enable NLS support" on \
+ GTK2 "Enable GTK2 gui" off
+
+.include <bsd.port.pre.mk>
+.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
.else
USE_GETTEXT= yes
-.for ii in de el es fr gl ja nl pl pt_BR ru sv uk zh_CN
+
+.for ii in ca de el es fr gl it ja nl pl pt_BR ru sv uk zh_CN
PLIST_FILES+= share/locale/${ii}/LC_MESSAGES/aumix.mo
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-pre-extract:
-.if !defined(WITH_GTK2) && !defined(WITHOUT_ALL)
- @${ECHO_CMD}
- @${ECHO_CMD} "****** To enable use of GTK+ 2.0, interrupt the ******"
- @${ECHO_CMD} "****** build now, set WITH_GTK2, and start again. ******"
- @${ECHO_CMD}
- @sleep 3
-.endif
-
pre-patch:
@${REINPLACE_CMD} -e "s:/etc:${PREFIX}/etc:" ${WRKSRC}/src/common.[ch]
-.if (${HAVE_GNOME:Mgtk12}!="") && !defined(WITHOUT_ALL) && \
- !defined(WITHOUT_GTK)&& !defined(WITH_GTK2)
-USE_GNOME= gtk12
-PKGNAMESUFFIX= -gtk
-CONFIGURE_ARGS+=--without-gtk
-.elif defined(WITH_GTK2)
+.if defined(WITH_GTK2)
PKGNAMESUFFIX= -gtk
USE_GNOME= gtk20
-CONFIGURE_ARGS+=--without-gtk1
.else
-CONFIGURE_ARGS+=--without-gtk --without-gtk1
+CONFIGURE_ARGS+=--without-gtk
.endif
.include <bsd.port.post.mk>
diff --git a/audio/aumix/distinfo b/audio/aumix/distinfo
index 900d73efa62f..ff091da1d6d2 100644
--- a/audio/aumix/distinfo
+++ b/audio/aumix/distinfo
@@ -1,3 +1,3 @@
-MD5 (aumix-2.8.tar.bz2) = dc3fc7209752207c23e7c94ab886b340
-SHA256 (aumix-2.8.tar.bz2) = 636eef7f400c2f3df489c0d2fa21507e88692113561e75a40a26c52bc422d7fc
-SIZE (aumix-2.8.tar.bz2) = 157503
+MD5 (aumix-2.9.1.tar.bz2) = 34f28ae1c94fc5298e8bb2688c4b3a20
+SHA256 (aumix-2.9.1.tar.bz2) = d2ce43d532ef75072c8d4e7922e3bc06be6d97765a508d9ceb0d1766bbe70e29
+SIZE (aumix-2.9.1.tar.bz2) = 231622
diff --git a/audio/aumix/files/patch-src_common.c b/audio/aumix/files/patch-src_common.c
deleted file mode 100644
index 67e50c8884bc..000000000000
--- a/audio/aumix/files/patch-src_common.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/common.c.orig 2009-10-17 15:53:40.000000000 +0200
-+++ src/common.c 2009-10-17 15:56:10.000000000 +0200
-@@ -216,6 +216,9 @@ int main(int argc, char *arg
- #if defined (HAVE_GTK) || defined (HAVE_GTK1)
- /* GTK+ stuff */
- if (interactive == IN_GTK) {
-+#if defined (HAVE_GTK) && defined (HAVE_NLS)
-+ bind_textdomain_codeset((char *) PACKAGE, "UTF-8");
-+#endif /* HAVE_GTK && HAVE_NLS */
- #ifndef DUMMY_MIXER
- if ((mixer_fd = open(device_filename, O_RDWR)) < 0)
- return EOPENMIX;