aboutsummaryrefslogtreecommitdiffstats
path: root/audio/aureal-kmod/files
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-01-16 01:42:47 +0800
committersobomax <sobomax@FreeBSD.org>2001-01-16 01:42:47 +0800
commit5e6f0b22cff37c0262ba4dc3d2f455b7678a0c7d (patch)
treecbb072ecba4d29f07bdb356ebb9c973c8e407b82 /audio/aureal-kmod/files
parent6da7ac726ea9424b6d7ac12cf07c9b33bffeb06e (diff)
downloadfreebsd-ports-gnome-5e6f0b22cff37c0262ba4dc3d2f455b7678a0c7d.tar.gz
freebsd-ports-gnome-5e6f0b22cff37c0262ba4dc3d2f455b7678a0c7d.tar.zst
freebsd-ports-gnome-5e6f0b22cff37c0262ba4dc3d2f455b7678a0c7d.zip
Move just-added aureal-kmod from misc into audio, because it better belongs
there. For those who missed decsription from previous commit: Add aureal-kmod - a port to provide convinient way for building FreeBSD driver for Aureal based soundcards. This driver could not be added to the base system because it's uses binary-only Linux Vortex Core object modules. The port supports 4-STABLE and 5-CURRENT, however 4-STABLE isn't tested, so please report your mileage to me. Suggested by: alex
Diffstat (limited to 'audio/aureal-kmod/files')
-rw-r--r--audio/aureal-kmod/files/patch-10_Makefile10
-rw-r--r--audio/aureal-kmod/files/patch-20_Makefile10
-rw-r--r--audio/aureal-kmod/files/patch-30_Makefile10
-rw-r--r--audio/aureal-kmod/files/patch-Makefile9
-rw-r--r--audio/aureal-kmod/files/patch-Makefile.inc15
-rw-r--r--audio/aureal-kmod/files/patch-au88x0.c14
6 files changed, 68 insertions, 0 deletions
diff --git a/audio/aureal-kmod/files/patch-10_Makefile b/audio/aureal-kmod/files/patch-10_Makefile
new file mode 100644
index 000000000000..f53fd9442836
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-10_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 10/Makefile.orig Mon Jan 15 18:45:58 2001
++++ 10/Makefile Mon Jan 15 18:46:31 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8810
++SRCS += asp10.o
++
++.include <bsd.kmod.mk>
diff --git a/audio/aureal-kmod/files/patch-20_Makefile b/audio/aureal-kmod/files/patch-20_Makefile
new file mode 100644
index 000000000000..974ca87c082b
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-20_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 20/Makefile.orig Mon Jan 15 18:45:59 2001
++++ 20/Makefile Mon Jan 15 18:46:34 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8820
++SRCS += asp20.o
++
++.include <bsd.kmod.mk>
diff --git a/audio/aureal-kmod/files/patch-30_Makefile b/audio/aureal-kmod/files/patch-30_Makefile
new file mode 100644
index 000000000000..e23040a13fe0
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-30_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 30/Makefile.orig Mon Jan 15 18:45:59 2001
++++ 30/Makefile Mon Jan 15 18:46:37 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8830
++SRCS += asp30.o
++
++.include <bsd.kmod.mk>
diff --git a/audio/aureal-kmod/files/patch-Makefile b/audio/aureal-kmod/files/patch-Makefile
new file mode 100644
index 000000000000..795b1e286dba
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-Makefile
@@ -0,0 +1,9 @@
+
+$FreeBSD$
+
+--- Makefile.orig Mon Jan 15 18:44:49 2001
++++ Makefile Mon Jan 15 18:44:49 2001
+@@ -0,0 +1,3 @@
++SUBDIR = 10 20 30
++
++.include <bsd.subdir.mk>
diff --git a/audio/aureal-kmod/files/patch-Makefile.inc b/audio/aureal-kmod/files/patch-Makefile.inc
new file mode 100644
index 000000000000..5662c830ea79
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-Makefile.inc
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- Makefile.inc.orig Mon Jan 15 18:44:49 2001
++++ Makefile.inc Mon Jan 15 18:44:49 2001
+@@ -0,0 +1,9 @@
++.PATH: /sys/dev/sound/pci ${WRKSRC}
++
++KMODDIR = ${PREFIX}/lib/au88x0
++SRCS = device_if.h bus_if.h isa_if.h pci_if.h
++SRCS += au88x0.c
++.if ${OSVERSION} > 500000
++SRCS += ac97_if.h channel_if.h feeder_if.h mixer_if.h
++.endif
++CFLAGS += -I${WRKSRC}
diff --git a/audio/aureal-kmod/files/patch-au88x0.c b/audio/aureal-kmod/files/patch-au88x0.c
new file mode 100644
index 000000000000..8c5b59f1c707
--- /dev/null
+++ b/audio/aureal-kmod/files/patch-au88x0.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- au88x0.c.orig Mon Jan 15 18:44:49 2001
++++ au88x0.c Mon Jan 15 18:44:49 2001
+@@ -32,7 +32,7 @@
+ */
+
+ #include <dev/sound/pcm/sound.h>
+-#include <dev/sound/pci/au88x0.h>
++#include "au88x0.h"
+
+ #include <pci/pcireg.h>
+ #include <pci/pcivar.h>