aboutsummaryrefslogtreecommitdiffstats
path: root/audio/blop/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-02 02:10:43 +0800
committerkrion <krion@FreeBSD.org>2004-03-02 02:10:43 +0800
commit83f7f65f562e179b3ecd68561861d7800670d599 (patch)
treef430912e217db5fda60fc16baa613b35ea4add67 /audio/blop/Makefile
parent48844b090bf82aaa33caa17bb83a7376b31989d4 (diff)
downloadfreebsd-ports-gnome-83f7f65f562e179b3ecd68561861d7800670d599.tar.gz
freebsd-ports-gnome-83f7f65f562e179b3ecd68561861d7800670d599.tar.zst
freebsd-ports-gnome-83f7f65f562e179b3ecd68561861d7800670d599.zip
- Fix build on non-i386 arch
PR: ports/63588 Submitted by: Ports Fury
Diffstat (limited to 'audio/blop/Makefile')
-rw-r--r--audio/blop/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
index 82c3d13bc05c..d5a3b1e939f1 100644
--- a/audio/blop/Makefile
+++ b/audio/blop/Makefile
@@ -23,14 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ladspa-prefix="${LOCALBASE}"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
-BROKEN= "Configure fails on alpha 5.x"
-.endif
-
post-patch:
- @${REINPLACE_CMD} 's|-pipe -Wall -O3 |\$$CFLAGS |g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|\$$(LIBS)|\$$(LIBS) \$$(LDFLAGS)|g ; \
s|-lc | |g'
@@ -38,4 +31,4 @@ post-patch:
pre-build:
cd ${WRKSRC}/src; ${GMAKE} sawtooth_data.h square_data.h parabola_data.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>