aboutsummaryrefslogtreecommitdiffstats
path: root/audio/blop/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-01 14:57:16 +0800
committerbapt <bapt@FreeBSD.org>2012-06-01 14:57:16 +0800
commitb557076221bc64a31bd5b376790cb714f486c893 (patch)
treeba92db0751c943ce993ff1ab39dfac9c225c1981 /audio/blop/Makefile
parent8033973ca84c7935f11bc3068cf3a5d5f6287da8 (diff)
downloadfreebsd-ports-gnome-b557076221bc64a31bd5b376790cb714f486c893.tar.gz
freebsd-ports-gnome-b557076221bc64a31bd5b376790cb714f486c893.tar.zst
freebsd-ports-gnome-b557076221bc64a31bd5b376790cb714f486c893.zip
Convert to new options framework
Diffstat (limited to 'audio/blop/Makefile')
-rw-r--r--audio/blop/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
index 101dd97a164e..704433b874cd 100644
--- a/audio/blop/Makefile
+++ b/audio/blop/Makefile
@@ -19,19 +19,19 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ladspa-prefix="${LOCALBASE}"
-OPTIONS= NLS "Native language support" on
+OPTIONS_DEFINE= NLS
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -39,4 +39,4 @@ post-patch:
's|$$(LIBS)$$|$$(LIBS) $$(LDFLAGS)|g ; \
s|-lc | |g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>