aboutsummaryrefslogtreecommitdiffstats
path: root/audio/bmp-scrobbler
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-15 04:12:55 +0800
committerpav <pav@FreeBSD.org>2005-01-15 04:12:55 +0800
commit99c04e920eb4659f190c28c5b270e79467cfa26a (patch)
tree9fc2e0d81ba3c177f7f19c94bc72cbfc90384458 /audio/bmp-scrobbler
parent392dfc368001f6e2067a68140b0e07834608a15f (diff)
downloadfreebsd-ports-gnome-99c04e920eb4659f190c28c5b270e79467cfa26a.tar.gz
freebsd-ports-gnome-99c04e920eb4659f190c28c5b270e79467cfa26a.tar.zst
freebsd-ports-gnome-99c04e920eb4659f190c28c5b270e79467cfa26a.zip
Add bmp-scrobbler, a Beep-Media-Player plugin for Audioscrobbler.com social
network. PR: ports/76252 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Diffstat (limited to 'audio/bmp-scrobbler')
-rw-r--r--audio/bmp-scrobbler/Makefile31
-rw-r--r--audio/bmp-scrobbler/distinfo2
-rw-r--r--audio/bmp-scrobbler/pkg-descr5
-rw-r--r--audio/bmp-scrobbler/pkg-plist2
4 files changed, 40 insertions, 0 deletions
diff --git a/audio/bmp-scrobbler/Makefile b/audio/bmp-scrobbler/Makefile
new file mode 100644
index 000000000000..4155fee7c88f
--- /dev/null
+++ b/audio/bmp-scrobbler/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: bmp-scrobbler
+# Date created: 01-14-2005
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+
+PORTNAME= bmp-scrobbler
+PORTVERSION= 0.3.6
+CATEGORIES= audio
+MASTER_SITES= http://static.audioscrobbler.com/plugins/
+DISTNAME= xmms-scrobbler-${PORTVERSION}
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= BMP plugin for Audioscrobbler.com
+
+LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
+ beep.2:${PORTSDIR}/multimedia/beep-media-player \
+ curl.3:${PORTSDIR}/ftp/curl
+
+CONFIGURE_ARGS= --disable-xmms-plugin
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.if defined(WITH_APE)
+CONFIGURE_ARGS+= --enable-prefer-ape
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/bmp-scrobbler/distinfo b/audio/bmp-scrobbler/distinfo
new file mode 100644
index 000000000000..57cf7becc113
--- /dev/null
+++ b/audio/bmp-scrobbler/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmms-scrobbler-0.3.6.tar.bz2) = eb5b53815eb91f5294f76ca424369b7f
+SIZE (xmms-scrobbler-0.3.6.tar.bz2) = 338393
diff --git a/audio/bmp-scrobbler/pkg-descr b/audio/bmp-scrobbler/pkg-descr
new file mode 100644
index 000000000000..8fac6800b59c
--- /dev/null
+++ b/audio/bmp-scrobbler/pkg-descr
@@ -0,0 +1,5 @@
+This is a BMP Plugin which sends the Playlist data to
+audioscrobbler.com
+
+WWW: http://www.audioscrobbler.com
+Author: pipian@pipian.com
diff --git a/audio/bmp-scrobbler/pkg-plist b/audio/bmp-scrobbler/pkg-plist
new file mode 100644
index 000000000000..cf789cc2f2c7
--- /dev/null
+++ b/audio/bmp-scrobbler/pkg-plist
@@ -0,0 +1,2 @@
+lib/bmp/General/libbmp_scrobbler.so
+@unexec rmdir %D/lib/bmp/General 2> /dev/null || true