aboutsummaryrefslogtreecommitdiffstats
path: root/audio/cmt/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-05-31 00:53:07 +0800
committerijliao <ijliao@FreeBSD.org>2002-05-31 00:53:07 +0800
commita9ee499e6059a463ab5026bab12ca92e091725d9 (patch)
tree5b29b07be4e7886b8b82f38d33258d2965193ac0 /audio/cmt/Makefile
parent8183ffa147981c94587f7990e02f2dc3495344ab (diff)
downloadfreebsd-ports-gnome-a9ee499e6059a463ab5026bab12ca92e091725d9.tar.gz
freebsd-ports-gnome-a9ee499e6059a463ab5026bab12ca92e091725d9.tar.zst
freebsd-ports-gnome-a9ee499e6059a463ab5026bab12ca92e091725d9.zip
add cmt 1.12
The Computer Music Toolkit (CMT) is a collection of LADSPA plugins PR: 37970 Submitted by: Tilman Linneweh <tilman@arved.de>
Diffstat (limited to 'audio/cmt/Makefile')
-rw-r--r--audio/cmt/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/audio/cmt/Makefile b/audio/cmt/Makefile
new file mode 100644
index 000000000000..217e7908e7fe
--- /dev/null
+++ b/audio/cmt/Makefile
@@ -0,0 +1,42 @@
+# New ports collection Makefile for: cmt
+# Date created: 11 May 2002
+# Whom: Tilman Linneweh <freebsdports@arved.de
+#
+# $FreeBSD$
+
+PORTNAME= cmt
+PORTVERSION= 1.12
+CATEGORIES= audio
+MASTER_SITES= http://www.ladspa.org/download/
+DISTNAME= ${PORTNAME}_src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= freebsdports@arved.de
+
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+MAKEFILE= makefile
+ALL_TARGET= targets
+
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.cpp' | ${XARGS} ${PERL} -pi -e \
+ 's|<malloc.h>|<stdlib.h>|g'
+
+.for i in ${WRKSRC}/analogue.cpp \
+ ${WRKSRC}/canyondelay.cpp \
+ ${WRKSRC}/lofi.cpp \
+ ${WRKSRC}/phasemod.cpp \
+ ${WRKSRC}/syndrum.cpp \
+ ${WRKSRC}/vcf303.cpp
+ ${MV} ${WRKDIR}/$i ${WRKDIR}/$i.sed
+ ${SED} -e "s:malloc.h:stdlib.h:g" \
+ ${WRKDIR}/$i.sed >${WRKDIR}/$i
+ ${RM} ${WRKDIR}/$i.sed
+.endfor
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/../plugins/cmt.so ${LOCALBASE}/lib/ladspa/
+
+.include <bsd.port.mk>