aboutsummaryrefslogtreecommitdiffstats
path: root/audio/cmus/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2006-08-09 20:32:59 +0800
committeradamw <adamw@FreeBSD.org>2006-08-09 20:32:59 +0800
commitfdc6743f015c1b50ee4edab1d5d6adcf7b1e4132 (patch)
tree111e9e7531f135c0db4f03fb1e2ab3677ff2045d /audio/cmus/Makefile
parent9d55eb9ad2969d86c7606e994256930dff4bf8b4 (diff)
downloadfreebsd-ports-gnome-fdc6743f015c1b50ee4edab1d5d6adcf7b1e4132.tar.gz
freebsd-ports-gnome-fdc6743f015c1b50ee4edab1d5d6adcf7b1e4132.tar.zst
freebsd-ports-gnome-fdc6743f015c1b50ee4edab1d5d6adcf7b1e4132.zip
Update to 2.0.2.
PR: ports/98792 Submitted by: maintainer
Diffstat (limited to 'audio/cmus/Makefile')
-rw-r--r--audio/cmus/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 7a45cb18c577..bef7da1da337 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cmus
-PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTVERSION= 2.0.2
CATEGORIES= audio
MASTER_SITES= http://onion.dynserv.net/~timo/files/ \
http://mirror.greaterscope.net/cmus/
@@ -97,13 +96,26 @@ PLIST_SUB+= ARTS="@comment "
PREMSG+= Define WITH_ARTS=yes to enable arts output support.\n
.endif
+MAN1= cmus.1 cmus-remote.1
+
pre-everything::
@${PRINTF} "${PREMSG}"
@${ECHO_CMD}
+post-extract:
+ @${REINPLACE_CMD} -e 's, -Wno-pointer-sign,,' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,$$(mandir)/man1,${PREFIX}/man/man1,' \
+ ${WRKSRC}/Doc/Makefile
+
post-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
"s|/bin/bash|${LOCALBASE}/bin/bash|; \
s|-lncursesw|-lncurses|g"
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/examples
+ ${INSTALL} ${WRKSRC}/cmus-status-display ${DOCSDIR}/examples
+.endif
+
.include <bsd.port.post.mk>