aboutsummaryrefslogtreecommitdiffstats
path: root/audio/csound/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-04-04 22:53:10 +0800
committerpav <pav@FreeBSD.org>2008-04-04 22:53:10 +0800
commit08de5d63dfa6411216d94e56f74919a8a5c58b2f (patch)
tree6f81f3138238fd1e8f9222739ae13e4e94c08df9 /audio/csound/Makefile
parentf2e966c11d6f0d0b103b8599ec3afa190cef2ffc (diff)
downloadfreebsd-ports-gnome-08de5d63dfa6411216d94e56f74919a8a5c58b2f.tar.gz
freebsd-ports-gnome-08de5d63dfa6411216d94e56f74919a8a5c58b2f.tar.zst
freebsd-ports-gnome-08de5d63dfa6411216d94e56f74919a8a5c58b2f.zip
- Update to 5.07
PR: ports/120102 Submitted by: Martin Tournoij <carpetsmoker@xs4all.nl> (maintainer)
Diffstat (limited to 'audio/csound/Makefile')
-rw-r--r--audio/csound/Makefile46
1 files changed, 26 insertions, 20 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 9ea8750454f1..fc664a1593e7 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -2,12 +2,12 @@
# Date created: 2000-10-11
# Whom: trevor
#
-# $Carpetsmoker: ports/audio/csound/Makefile,v 1.3 2007/07/22 00:52:59 carpetsmoker Exp $
+# $Carpetsmoker: ports/audio/csound/Makefile,v 1.5 2007/11/18 11:10:22 carpetsmoker Exp $
# $FreeBSD$
#
PORTNAME= csound
-PORTVERSION= 5.06
+PORTVERSION= 5.07
CATEGORIES= audio lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.carpetsmoker.net/distfiles/:manual \
@@ -22,34 +22,46 @@ MAINTAINER= carpetsmoker@xs4all.nl
COMMENT= Sound synthesizer
LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads \
- portaudio.2:${PORTSDIR}/audio/portaudio2
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
-WRKSRC= ${WRKDIR}/${DISTNAME:S/_src/.0/}
+WRKSRC= ${WRKDIR}/csound5
USE_PYTHON= 2.4+
USE_SCONS= yes
SCONS_ARGS+= prefix=${PREFIX} CC=${CC} CXX=${CXX} \
- buildRelease=1 install=1 buildCsound5GUI=1 \
- buildWinsound=1 buildVirtual=1 buildCSEditor=1 Word64=1
-SUB_FILES= custom.py \
- pkg-message
-SUB_LIST+= PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR}
+ usePortAudio=0 usePortMIDI=0 useALSA=0 \
+ useJack=0 useFLTK=1 buildCsoundAC=0 buildCsoundVST=0 \
+ buildCsound5GUI=1 buildRelease=1 install=1 \
+ useCoreAudio=1 buildWinsound=1 buildInterfaces=1 \
+ buildVirtual=1 buildCSEditor=1 buildDSSI=0
+SUB_FILES= custom.py pkg-message
+SUB_LIST+= PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR} \
+ PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
USE_LDCONFIG= yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+USE_LDCONFIG= ${PREFIX}/lib/csound/plugins
+
+.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
DISTFILES+= ${DISTNAME}-manual.tar.gz:manual
.endif
-FLTKBASE?= ${LOCALBASE}
+.if ${ARCH} == "sparc64"
+BROKEN= Fails to link
+.endif
+
post-patch: apply-slist
@${SETENV} FLTKBASE=${FLTKBASE} ${SH} ${SCRIPTDIR}/check-fltk-threads.sh
@${MV} ${WRKDIR}/custom.py ${WRKSRC}
@${REINPLACE_CMD} -e "s|'unsupported'|'linux'|; \
s|ENV = {'PATH' : os.environ\['PATH'\]}|ENV = os.environ|; \
- s|'dl'|''| ; s|lib64|lib|g" \
+ s|'dl'|''|; \
+ s|'asound'|''|;" \
${WRKSRC}/SConstruct
@${REINPLACE_CMD} 's|linux/if.h|net/if.h|' ${WRKSRC}/OOps/remote.c
+ @${REINPLACE_CMD} 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/frontends/CsoundAC/Counterpoint.hpp
post-install:
.if !defined(NOPORTDOCS)
@@ -57,13 +69,7 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/csound-manual/tutorial_${PORTVERSION}.pdf ${DOCSDIR}
${CP} -r ${WRKDIR}/csound-manual/html ${DOCSDIR}
.endif
- ${MV} ${PREFIX}/bin/mixer ${PREFIX}/bin/cs_mixer
- @${CAT} ${WRKDIR}/pkg-message
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Fails to link
-.endif
+ ${MV} ${PREFIX}/bin/mixer ${PREFIX}/bin/csmixer
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>