aboutsummaryrefslogtreecommitdiffstats
path: root/audio/csound/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2000-10-12 09:58:05 +0800
committertrevor <trevor@FreeBSD.org>2000-10-12 09:58:05 +0800
commit00661a96c01c0cd4cb33314525e62581138f1775 (patch)
tree24d5b6f1d03d8a4e08ee2b15116139896fe48289 /audio/csound/Makefile
parentbf2bf0c0b202351e454b02e400b609c7f2b045be (diff)
downloadfreebsd-ports-gnome-00661a96c01c0cd4cb33314525e62581138f1775.tar.gz
freebsd-ports-gnome-00661a96c01c0cd4cb33314525e62581138f1775.tar.zst
freebsd-ports-gnome-00661a96c01c0cd4cb33314525e62581138f1775.zip
Add a port for the sound synthesizer Csound. Add a port for its manuals.
Diffstat (limited to 'audio/csound/Makefile')
-rw-r--r--audio/csound/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
new file mode 100644
index 000000000000..c2ee9580ba7f
--- /dev/null
+++ b/audio/csound/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: csound
+# Date created: 2000-10-11
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= csound
+PORTVERSION= 4.08
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.maths.bath.ac.uk/pub/dream/newest/
+DISTFILES= Csound.tar.gz
+.if !defined(NOPORTDOCS)
+DISTFILES+= Version${PORTVERSION:S/./_/}.Notes
+.endif
+DIST_SUBDIR= csound
+EXTRACT_ONLY= Csound.tar.gz
+
+MAINTAINER= trevor@FreeBSD.org
+
+LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
+ tk83:${PORTSDIR}/x11-toolkits/tk83
+
+RESTRICTED= "no redistribution; no commercial use except to make music (see http://mitpress.mit.edu/e-books/csound/fpage/FAQml/faq/faq.html#THE CSOUND COPYRIGHT ISSUES)"
+
+MAKE_ENV= CPPFLAGS="-I${PREFIX}/include" \
+ LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
+NO_WRKSUBDIR= yes
+USE_X_PREFIX= yes
+
+pre-build:
+ ${RM} -f ${PLIST}
+.for i in bin/csound share/csound/csound.dat
+ ${ECHO} ${i} >> ${PLIST}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${ECHO} share/doc/csound/Version${PORTVERSION:S/./_/}.Notes >> ${PLIST}
+ ${ECHO} "@dirrm share/doc/csound" >> ${PLIST}
+.endif
+ ${ECHO} "@dirrm share/csound" >> ${PLIST}
+
+post-patch:
+ ${PERL} -pi -e "s:PREFIX:${PREFIX}:g" ${WRKSRC}/getstring.c
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/csound
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/csound
+ ${INSTALL_DATA} ${_DISTDIR}/Version${PORTVERSION:S/./_/}.Notes \
+ ${PREFIX}/share/doc/csound
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/csound ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/csound.txt ${PREFIX}/share/csound/csound.dat
+
+post-clean:
+ ${RM} -f ${PLIST}
+
+.include <bsd.port.mk>