aboutsummaryrefslogtreecommitdiffstats
path: root/audio/csound6
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-02-07 23:53:49 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-02-07 23:53:49 +0800
commitbb77c99f70ac60e074352286015d12f070a9d584 (patch)
tree0804110c91c58260d655fda16627b42c79e0a9c5 /audio/csound6
parent64def7588df8ffe4e6997b9577fd3f411742fab2 (diff)
downloadfreebsd-ports-gnome-bb77c99f70ac60e074352286015d12f070a9d584.tar.gz
freebsd-ports-gnome-bb77c99f70ac60e074352286015d12f070a9d584.tar.zst
freebsd-ports-gnome-bb77c99f70ac60e074352286015d12f070a9d584.zip
- Fix build with boost 1.60
- Fix license - Switch to USES=localbase
Diffstat (limited to 'audio/csound6')
-rw-r--r--audio/csound6/Makefile8
-rw-r--r--audio/csound6/files/patch-Opcodes_chua_ChuaOscillator.cpp12
2 files changed, 15 insertions, 5 deletions
diff --git a/audio/csound6/Makefile b/audio/csound6/Makefile
index a3775942faf5..ddd4836bfdc7 100644
--- a/audio/csound6/Makefile
+++ b/audio/csound6/Makefile
@@ -12,7 +12,8 @@ DIST_SUBDIR= csound
MAINTAINER= ports@FreeBSD.org
COMMENT= Sound synthesizer
-LICENSE= LGPL21
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= boost-libs>0:${PORTSDIR}/devel/boost-libs \
swig>2:${PORTSDIR}/devel/swig20 \
@@ -21,7 +22,7 @@ BUILD_DEPENDS= boost-libs>0:${PORTSDIR}/devel/boost-libs \
LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libsndfile.so:${PORTSDIR}/audio/libsndfile
-USES= bison cmake python:2
+USES= bison cmake localbase python:2
CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
-DBUILD_JAVA_INTERFACE:BOOL=OFF \
-DBUILD_P5GLOVE_OPCODES:BOOL=OFF \
@@ -33,9 +34,6 @@ CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
USE_LDCONFIG= yes
SSP_UNSAFE= yes
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
SUB_FILES= pkg-message
CONFLICTS= csound-5.*
diff --git a/audio/csound6/files/patch-Opcodes_chua_ChuaOscillator.cpp b/audio/csound6/files/patch-Opcodes_chua_ChuaOscillator.cpp
new file mode 100644
index 000000000000..107c7065cc5c
--- /dev/null
+++ b/audio/csound6/files/patch-Opcodes_chua_ChuaOscillator.cpp
@@ -0,0 +1,12 @@
+--- Opcodes/chua/ChuaOscillator.cpp.orig 2015-09-29 11:13:27 UTC
++++ Opcodes/chua/ChuaOscillator.cpp
+@@ -117,8 +117,8 @@
+ // d = sys_variables(12);
+ // gnor = a*(x.^3) + b*(x.^2) + c*x + d;
+
+-#include <OpcodeBase.hpp>
+ #include <boost/numeric/ublas/vector.hpp>
++#include <OpcodeBase.hpp>
+ using namespace boost::numeric;
+ #include <cmath>
+