aboutsummaryrefslogtreecommitdiffstats
path: root/audio/csound
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-08-22 21:06:29 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-08-22 21:06:29 +0800
commit82c6b5fd03fc03948bdbd7e7a958c14398824e46 (patch)
treebac654ed1661d74c500b86c1e0d0547aa3d4f090 /audio/csound
parent2b88e46be27f2f74add49696dfe981d2fdbe1d30 (diff)
downloadfreebsd-ports-gnome-82c6b5fd03fc03948bdbd7e7a958c14398824e46.tar.gz
freebsd-ports-gnome-82c6b5fd03fc03948bdbd7e7a958c14398824e46.tar.zst
freebsd-ports-gnome-82c6b5fd03fc03948bdbd7e7a958c14398824e46.zip
- Add PNG option to fix plist (libimage.so is optional)
- DSSI option requires alsa library - Fix DOCS option
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile21
-rw-r--r--audio/csound/files/patch-SConstruct11
-rw-r--r--audio/csound/pkg-plist2
3 files changed, 30 insertions, 4 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index fd20a0fe8c60..8718fd7b04b3 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -3,6 +3,7 @@
PORTNAME= csound
PORTVERSION= 5.19.01
+PORTREVISION= 1
CATEGORIES= audio lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R} \
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R}/manual:manual
@@ -22,10 +23,11 @@ LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
PORTSCOUT= limit:^5\.
-OPTIONS_DEFINE= ALSA DSSI FLTK FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO DOCS
+OPTIONS_DEFINE= ALSA PNG DSSI FLTK FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO DOCS
OPTIONS_DEFAULT=FLTK
OPTIONS_SUB= yes
ALSA_DESC= Build ALSA I/O module
+PNG_DESC= Build image opcodes
DSSI_DESC= Build DSSI/LADSPA host opcodes
FLUIDSYNTH_DESC=Building FluidSynth opcodes
JACK_DESC= Build Jack I/O module and opcodes
@@ -38,8 +40,7 @@ CONFLICTS_INSTALL= outguess-* csound6
WRKSRC= ${WRKDIR}/${PORTNAME:S/c/C/}${PORTVERSION}
-USES= bison gettext scons compiler:openmp
-USE_PYTHON= yes
+USES= bison gettext scons compiler:openmp python
MAKE_ARGS= instdir="${STAGEDIR}" prefix="${PREFIX}" \
CC="${CC}" CXX="${CXX}" \
buildCsoundAC=0 buildCsoundVST=0 buildInterfaces=1 \
@@ -65,8 +66,16 @@ MAKE_ARGS+= useALSA=0
ALSA_H= ##alsa/asoundlib.h##
.endif
+.if ${PORT_OPTIONS:MPNG}
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png
+MAKE_ARGS+= buildImageOpcodes=1
+.else
+MAKE_ARGS+= buildImageOpcodes=0
+.endif
+
.if ${PORT_OPTIONS:MDSSI}
BUILD_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
+LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
RUN_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
MAKE_ARGS+= buildDSSI=1
.else
@@ -141,6 +150,8 @@ CXXLIB= c++
CXXLIB= # empty
.endif
+.include <bsd.port.options.mk>
+
post-patch:
@${SED} -e "s|%%LOCALBASE%%|${LOCALBASE}|g; \
s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|; \
@@ -179,7 +190,11 @@ post-patch:
post-install:
${LN} -sf libcsound64.so.5 ${STAGEDIR}${PREFIX}/lib/libcsound64.so
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKDIR}/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+.endif
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/*.so* \
+ ${STAGEDIR}${PREFIX}/lib/csound/plugins64/*.so
.include <bsd.port.post.mk>
diff --git a/audio/csound/files/patch-SConstruct b/audio/csound/files/patch-SConstruct
new file mode 100644
index 000000000000..da73267d75e3
--- /dev/null
+++ b/audio/csound/files/patch-SConstruct
@@ -0,0 +1,11 @@
+--- SConstruct.orig 2013-01-07 16:49:34.000000000 +0400
++++ SConstruct 2014-08-22 15:37:51.000000000 +0400
+@@ -2057,7 +2057,7 @@
+
+ # DSSI HOST OPCODES
+
+-if (commonEnvironment['buildDSSI'] == '1' and (getPlatform() == 'linux' or getPlatform() == 'darwin') and configure.CheckHeader("ladspa.h", language = "C")) and configure.CheckHeader("dssi.h", language = "C"):
++if (commonEnvironment['buildDSSI'] == '1'):
+ print "CONFIGURATION DECISION: Building DSSI plugin host opcodes."
+ dssiEnvironment = pluginEnvironment.Clone()
+ dssiEnvironment.Append(LIBS = ['dl'])
diff --git a/audio/csound/pkg-plist b/audio/csound/pkg-plist
index fbcf21132a6b..a59cbf2aa1e7 100644
--- a/audio/csound/pkg-plist
+++ b/audio/csound/pkg-plist
@@ -58,7 +58,7 @@ lib/csound/plugins64/libdoppler.so
lib/csound/plugins64/libfareygen.so
%%FLUIDSYNTH%%lib/csound/plugins64/libfluidOpcodes.so
lib/csound/plugins64/libfractalnoise.so
-lib/csound/plugins64/libimage.so
+%%PNG%%lib/csound/plugins64/libimage.so
lib/csound/plugins64/libipmidi.so
%%JACK%%lib/csound/plugins64/libjackTransport.so
%%JACK%%lib/csound/plugins64/libjacko.so