aboutsummaryrefslogtreecommitdiffstats
path: root/audio/csound
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-23 13:00:25 +0800
committeredwin <edwin@FreeBSD.org>2007-09-23 13:00:25 +0800
commit11b57eec2ac1a0e6178e72e98eac5537ad16e70d (patch)
tree326f3afc3e59b9db7739fb6e60027a3219d7a66f /audio/csound
parentbd985a8ad8e4f91cc6f9a2422ae37a5687155554 (diff)
downloadfreebsd-ports-gnome-11b57eec2ac1a0e6178e72e98eac5537ad16e70d.tar.gz
freebsd-ports-gnome-11b57eec2ac1a0e6178e72e98eac5537ad16e70d.tar.zst
freebsd-ports-gnome-11b57eec2ac1a0e6178e72e98eac5537ad16e70d.zip
[PATCH, UPDATE] Update audio/csound and audio/csound-manual
Update audio/csound to 5.06 csound has been "liberated" and is now GPL, see http://csounds.com/VercoeGift.html The corresponding csound entry in LEGAL should be removed, note that csound-manual isn't updated to 5.06 and is still subject to a restrictive license. With thanks to Erik Trulsson and Mel at -questions for patch-Top-csound.c PR: ports/116255 Submitted by: Martin Tournoij <carpetsmoker@xs4all.nl>
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile95
-rw-r--r--audio/csound/distinfo9
-rw-r--r--audio/csound/files/custom.py.in12
-rw-r--r--audio/csound/files/patch-Makefile108
-rw-r--r--audio/csound/files/patch-Top-csound.c64
-rw-r--r--audio/csound/files/patch-anal_adsyn_makef21
-rw-r--r--audio/csound/files/patch-anal_convol_makef11
-rw-r--r--audio/csound/files/patch-anal_lpc_makef13
-rw-r--r--audio/csound/files/patch-anal_pvoc_makef13
-rw-r--r--audio/csound/files/patch-aops.c18
-rw-r--r--audio/csound/files/patch-cs_h11
-rw-r--r--audio/csound/files/patch-util1_cscore_makef22
-rw-r--r--audio/csound/files/patch-util2_dnoise.dir_makef24
-rw-r--r--audio/csound/files/patch-util2_dnoise_dir_dnoise_c10
-rw-r--r--audio/csound/files/patch-util2_dnoise_dir_srconv_c10
-rw-r--r--audio/csound/files/pkg-message.in4
-rw-r--r--audio/csound/pkg-descr39
17 files changed, 149 insertions, 335 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 72d36b073dd9..29d05e157df5 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -2,64 +2,61 @@
# Date created: 2000-10-11
# Whom: trevor
#
+# $Carpetsmoker: ports/audio/csound/Makefile,v 1.3 2007/07/22 00:52:59 carpetsmoker Exp $
# $FreeBSD$
#
PORTNAME= csound
-PORTVERSION= 4.23
-PORTREVISION= 1
-CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_NETBSD}
+PORTVERSION= 5.06
+CATEGORIES= audio lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.carpetsmoker.net/distfiles/:manual \
+ http://www.xs4all.nl/~tournoij/distfiles/:manual \
+ http://www.rwxrwxrwx.net/distfiles/:manual
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= Csound${PORTVERSION}
+DISTNAME= ${PORTNAME:S/c/C/}${PORTVERSION}.0
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= csound
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= carpetsmoker@xs4all.nl
COMMENT= Sound synthesizer
-LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
- tk84:${PORTSDIR}/x11-toolkits/tk84
-
-RESTRICTED= no redistribution; no commercial use except to make music (see http://mitpress.mit.edu/e-books/csound/fpage/FAQml/faq/faq.html)
-NO_CDROM= ${RESTRICTED}
-NO_FTP= ${RESTRICTED}
-
-MAKE_ENV= CPPFLAGS="-I${PREFIX}/include" \
- LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
-NO_WRKSUBDIR= yes
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST= ${WRKDIR}/pkg-plist
-USE_X_PREFIX= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha"
-BROKEN= Does not compile on alpha
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile \
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads \
+ portaudio.2:${PORTSDIR}/audio/portaudio2
+BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_src/.0/}
+USE_PYTHON= 2.4+
+USE_SCONS= yes
+SCONS_ARGS+= prefix=${PREFIX} CC=${CC} CXX=${CXX} \
+ buildRelease=1 install=1 buildCsound5GUI=1 \
+ buildWinsound=1 buildVirtual=1 buildCSEditor=1
+SUB_FILES= custom.py \
+ pkg-message
+SUB_LIST+= PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR}
+USE_LDCONFIG= yes
+
+.if !defined(NOPORTDOCS)
+DISTFILES+= ${DISTNAME}-manual.tar.gz:manual
.endif
-pre-build:
- @${FIND} ${WRKDIR} -type f -exec ${CHMOD} 644 \{\} \;
-
-post-build:
- ${RM} -f ${PLIST}
- for i in `${FIND} ${WRKDIR} -type f -perm 755`; do \
- ${ECHO_CMD} bin/`${BASENAME} $${i}` >> ${PLIST}; \
- done
- ${ECHO_CMD} share/csound/csound.xmg >> ${PLIST}
- ${ECHO_CMD} "@dirrm share/csound" >> ${PLIST}
- ${ECHO_CMD} "*** WARNING ***" > ${PKGMESSAGE}
- ${ECHO_CMD} "The sources for the csound package have not been" >> ${PKGMESSAGE}
- ${ECHO_CMD} "thoroughly reviewed by the FreeBSD maintainer." >> ${PKGMESSAGE}
-
-post-patch:
- @${REINPLACE_CMD} -i "" -e "s:/usr/local/lib:${DATADIR}:g" ${WRKSRC}/getstring.c
- @${FIND} ${WRKSRC} -type f -exec \
- ${REINPLACE_CMD} -i -e 's:<malloc.h>:<stdlib.h>:g' {} \;
-
-do-install:
- ${MKDIR} ${PREFIX}/share/csound
- ${INSTALL_DATA} ${WRKSRC}/csound.xmg ${DATADIR}/csound.xmg
- ${FIND} ${WRKDIR} -type f -perm 755 \
- -exec ${INSTALL_PROGRAM} {} ${PREFIX}/bin \;
+post-patch: apply-slist
+ @/bin/sh ${SCRIPTDIR}/check-fltk-threads.sh
+ @${MV} ${WRKDIR}/custom.py ${WRKSRC}
+ @${REINPLACE_CMD} -e "s|'unsupported'|'linux'|; \
+ s|ENV = {'PATH' : os.environ\['PATH'\]}|ENV = os.environ|; \
+ s|'dl'|''|" \
+ ${WRKSRC}/SConstruct
+ @${REINPLACE_CMD} 's|linux/if.h|net/if.h|' ${WRKSRC}/OOps/remote.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/csound-manual/tutorial_${PORTVERSION}.pdf ${DOCSDIR}
+ ${CP} -r ${WRKDIR}/csound-manual/html ${DOCSDIR}
+.endif
+ ${MV} ${PREFIX}/bin/mixer ${PREFIX}/bin/cs_mixer
+ @${CAT} ${WRKDIR}/pkg-message
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index c70733f16051..9b2bbc23a14d 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1,3 +1,6 @@
-MD5 (csound/Csound4.23.tar.gz) = 194440772229410ed5f5f1bc07304d2d
-SHA256 (csound/Csound4.23.tar.gz) = 56525e0f3a6fa336788158a577004ec4adf7c8c114763081b5a9c3239ef0b8dc
-SIZE (csound/Csound4.23.tar.gz) = 1172388
+MD5 (csound/Csound5.06.0.tar.gz) = a17b46ffd42b448b374e2dbcdf698e90
+SHA256 (csound/Csound5.06.0.tar.gz) = 2a25c3d442c0abe12d83706650e1c6324866acc658af074daa9d60c0a69dbab1
+SIZE (csound/Csound5.06.0.tar.gz) = 11267389
+MD5 (csound/Csound5.06.0-manual.tar.gz) = 62b4a8edf5d26871092b8412a1f35a3b
+SHA256 (csound/Csound5.06.0-manual.tar.gz) = 01ad6e2d460ff144d687d545d0cc88d0f351d7df4c7d252bc73de5be61e3cdef
+SIZE (csound/Csound5.06.0-manual.tar.gz) = 10538560
diff --git a/audio/csound/files/custom.py.in b/audio/csound/files/custom.py.in
new file mode 100644
index 000000000000..8022140e1f9b
--- /dev/null
+++ b/audio/csound/files/custom.py.in
@@ -0,0 +1,12 @@
+# Order is important: place local paths ahead of system paths.
+
+import sys
+
+customCPPPATH = [ '%%LOCALBASE%%/include', '%%PYTHON_INCLUDEDIR%%' ]
+customCCFLAGS = [ ]
+customCXXFLAGS = [ ]
+customLIBS = []
+customLIBPATH = [ '%%LOCALBASE%%/lib' ]
+customSHLINKFLAGS = []
+customSWIGFLAGS = []
+platform = 'linux'
diff --git a/audio/csound/files/patch-Makefile b/audio/csound/files/patch-Makefile
deleted file mode 100644
index c4a8c8eb4ba9..000000000000
--- a/audio/csound/files/patch-Makefile
+++ /dev/null
@@ -1,108 +0,0 @@
---- Makefile.orig Thu Apr 24 15:00:58 2003
-+++ Makefile Thu Apr 24 15:03:27 2003
-@@ -1,17 +1,17 @@
- # Csound Makefile
- # edit the following definitions according to need:
-
--INCLUDE = /usr/local/include
--LIB = /usr/local/lib
--DEST = /usr/local/bin
--MAN = /usr/local/man
-+INCLUDE = $(PREFIX)/include
-+LIB = $(PREFIX)/lib
-+DEST = $(PREFIX)/bin
-+MAN = $(PREFIX)/man
- MAN1 = $(MAN)/man1
- CAT1 = $(MAN)/cat1
- # these directories must exist for stages beyond 'make csound'
-
- CDEP =
- COBS = $(COBJS)
--CC = cc
-+CC ?= cc
- # choose either -
- # CDEP = for UNIX
- # COBS = $(COBJS)
-@@ -23,7 +23,7 @@
- # .c.o:
- # $(CC) $(CFLAGS) -c $*.c -o $@
-
--DEFINES = -DWINDOWS -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK -DIV_SCHED -DHAVE_FLTK
-+DEFINES = -DRTAUDIO -DSFIRCAM -DSYS5 -DLINUX -DPIPES -DMACROS -DTCLTK -DIV_SCHED -DFREE_BSD
- # choose any of -
- # -DSYS5 invoke System 5 headers (e.g. 'string.h' for 'strings.h')
- # -DWINDOWS include window system calls (X11, SGI, or FG graphics)
-@@ -50,7 +50,7 @@
- # (e.g., Linux on SPARC [not tested]), you should also define -
- # -DLINUX_BE Linux audio device handler for big-endian samples
-
--CFLAGS = -Wall -O2 -malign-loops=4 -malign-jumps=4 -ffast-math -fomit-frame-pointer -finline-functions -funroll-loops -DWITHx87 $(RPM_OPT_FLAGS) $(DEFINES)
-+CFLAGS = $(CPPFLAGS) $(LDFLAGS) $(DEFINES)
- # -O Simple optimisation
- # -O2 to be more specific about the optimization level
- # -f compile single-precision floats (4.3,VAX,DEC-RISC)
-@@ -88,14 +88,14 @@
-
- # uncomment these if HAVE_FLTK was enabled in DEFINES
- #
--CXX = g++
--CXXFLAGS = -fno-exceptions -fno-rtti
--FLTKSRC = widgets.cpp
--FLTKOBJ = widgets.o
-+CXX ?= g++
-+#CXXFLAGS = -fno-exceptions -fno-rtti
-+#FLTKSRC = widgets.cpp
-+#FLTKOBJ = widgets.o
- # source and object files for FLTK widgets
- #FLTKLIB = -lfltk -lpthread -lg++
--FLTKLIB = /usr/local/lib/libfltk.a /usr/lib/libpthread.a \
-- /usr/lib/libstdc++-libc6.2-2.a.3
-+#FLTKLIB = /usr/local/lib/libfltk.a /usr/lib/libpthread.a \
-+# /usr/lib/libstdc++-libc6.2-2.a.3
- # libraries required by widgets.cpp
- # -lfltk -lpthread -lg++ use dynamic libraries
- #
-@@ -105,7 +105,7 @@
- # directiories and version
- # numbers are system-dependent)
-
--LIBS = $(FLTKLIB) -L /usr/X11R6/lib -lX11 -ltcl -ltk -lm -ldl
-+LIBS = -L$(X11BASE)/lib -L$(LOCALBASE)/lib -lX11 -ltcl84 -ltk84 -lm
- # -lefence
- # -lm required
- # -lX11 for X window calls
-@@ -124,8 +124,8 @@
- # note: SuSE 7.3 users should use -ltcl8.3 -ltk8.3, but another
- # (probably better) solution is to create symbolic links
-
--WINSRC = winFLTK.c FL_graph.cpp
--WINOBJ = winFLTK.o FL_graph.o
-+#WINSRC = winFLTK.c FL_graph.cpp
-+#WINOBJ = winFLTK.o FL_graph.o
- # ;if WINDOWS enabled in DEFINES, choose one of -
- # winX11.o for X11 window graphics
- # winSGI.o for SGI window graphics
-@@ -133,10 +133,10 @@
- # winFLTK.o and FL_graph.o for `improved' X graphics
- # and many others....winbor, wincwin
-
--#AUDSRC = rtlinux.c LINUXaudio.c
--#AUDOBJ = rtlinux.o LINUXaudio.o
--AUDSRC = rtalsa.c
--AUDOBJ = rtalsa.c
-+AUDSRC = rtlinux.c LINUXaudio.c
-+AUDOBJ = rtlinux.o LINUXaudio.o
-+#AUDSRC = rtalsa.c
-+#AUDOBJ = rtalsa.c
- # ;if RTAUDIO enabled in DEFINES, include one of
- # rtaudio.o general interface to audio handlers & libraries
- # rtDEC.c rtSGI.c rtHP.c rtSUN.c
-@@ -283,7 +283,7 @@
- all: $(PROGS) $(SUBDIRS) #must be run in this order
-
- csound: $(COBJS) $(CSUM) $(CDEP) csound.xmg
-- $(CC) $(CFLAGS) -o csound $(COBJS) $(LIBS)
-+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o csound $(COBJS) $(LIBS)
-
- TAGS: $(CSRCS) $(HDRS)
- etags $(CSRCS) $(HDRS)
diff --git a/audio/csound/files/patch-Top-csound.c b/audio/csound/files/patch-Top-csound.c
new file mode 100644
index 000000000000..f18009c93a01
--- /dev/null
+++ b/audio/csound/files/patch-Top-csound.c
@@ -0,0 +1,64 @@
+--- Top/csound.c.orig 2007-06-03 04:03:48.000000000 +0200
++++ Top/csound.c 2007-09-10 00:52:03.000000000 +0200
+@@ -54,6 +54,7 @@
+ #include "namedins.h"
+ #include "pvfileio.h"
+ #include "fftlib.h"
++#include <sys/sysctl.h>
+
+ extern void MakeAscii(CSOUND *, WINDAT *, const char *);
+ extern void DrawAscii(CSOUND *, WINDAT *);
+@@ -2444,46 +2445,17 @@
+ static int getTimeResolution(void)
+ {
+ #if defined(HAVE_RDTSC)
+- FILE *f;
+- char buf[256];
++ size_t size;
++ int timeResolutionSeconds;
++ size = sizeof timeResolutionSeconds;
++ sysctlbyname("hw.clockrate", &timeResolutionSeconds, &size, NULL, 0);
+
+- /* if frequency is not known yet */
+- f = fopen("/proc/cpuinfo", "r");
+- if (f == NULL) {
+- fprintf(stderr, "Cannot open /proc/cpuinfo. "
+- "Support for RDTSC is not available.\n");
+- return -1;
+- }
+- /* find CPU frequency */
+- while (fgets(buf, 256, f) != NULL) {
+- int i;
+- char *s = (char*) buf - 1;
+-
+- buf[255] = '\0'; /* safety */
+- if (strlen(buf) < 9)
+- continue; /* too short, skip */
+- while (*++s != '\0')
+- if (isupper(*s))
+- *s = tolower(*s); /* convert to lower case */
+- if (strncmp(buf, "cpu mhz", 7) != 0)
+- continue; /* check key name */
+- s = strchr(buf, ':'); /* find frequency value */
+- if (s == NULL) continue; /* invalid entry */
+- do {
+- s++;
+- } while (*s == ' ' || *s == '\t'); /* skip white space */
+- i = sscanf(s, "%lf", &timeResolutionSeconds);
+- if (i < 1 || timeResolutionSeconds < 1.0) {
+- timeResolutionSeconds = -1.0; /* invalid entry */
+- continue;
+- }
+- }
+- fclose(f);
+- if (timeResolutionSeconds <= 0.0) {
++ if (timeResolutionSeconds <= 0.0) {
+ fprintf(stderr, "No valid CPU frequency entry "
+- "was found in /proc/cpuinfo.\n");
++ "was found.\n");
+ return -1;
+ }
++
+ /* MHz -> seconds */
+ timeResolutionSeconds = 0.000001 / timeResolutionSeconds;
+ #elif defined(WIN32)
diff --git a/audio/csound/files/patch-anal_adsyn_makef b/audio/csound/files/patch-anal_adsyn_makef
deleted file mode 100644
index c7dec2eb6554..000000000000
--- a/audio/csound/files/patch-anal_adsyn_makef
+++ /dev/null
@@ -1,21 +0,0 @@
---- anal/adsyn/makef.orig Tue Oct 8 15:49:08 2002
-+++ anal/adsyn/makef Thu Apr 24 14:49:25 2003
-@@ -6,7 +6,7 @@
-
- OBJS = main.o $T/hetro.o $T/filopen.o $T/sfheader.o $T/soundin.o \
- $T/ulaw.o $T/aiff.o $T/ieee80.o $T/memalloc.o $T/wave.o \
-- $T/window.o $T/winFLTK.o $T/FL_graph.o $T/winEPS.o $T/aifc.o \
-+ $T/window.o $T/winEPS.o $T/aifc.o \
- $T/winascii.o $T/sdif.o $T/sdif-mem.o $T/getstring.o
-
- adsyns: hetro
-@@ -23,7 +23,7 @@
- cc $(CFLAGS) -c main.c
-
- clean:
-- -rm -f hetro
-+ -rm -f hetro *.o
-
- rmbak:
-- -rm *.bak *~
-+ -rm -f *.bak *~
diff --git a/audio/csound/files/patch-anal_convol_makef b/audio/csound/files/patch-anal_convol_makef
deleted file mode 100644
index 8e91f90aa601..000000000000
--- a/audio/csound/files/patch-anal_convol_makef
+++ /dev/null
@@ -1,11 +0,0 @@
---- anal/convol/makef.orig Thu Apr 24 14:59:47 2003
-+++ anal/convol/makef Thu Apr 24 15:00:08 2003
-@@ -7,7 +7,7 @@
- OBJS = main.o $T/cvanal.o $T/fft.o $T/dsputil.o $T/filopen.o \
- $T/sfheader.o $T/soundin.o $T/ulaw.o $T/aiff.o $T/ieee80.o \
- $T/memalloc.o $T/wave.o $T/window.o $T/aifc.o $T/getstring.o \
-- $T/winFLTK.o $T/FL_graph.o $T/winEPS.o $T/winascii.o
-+ $T/winEPS.o $T/winascii.o
-
-
- cvl: cvanal
diff --git a/audio/csound/files/patch-anal_lpc_makef b/audio/csound/files/patch-anal_lpc_makef
deleted file mode 100644
index 0a8a8d4d096e..000000000000
--- a/audio/csound/files/patch-anal_lpc_makef
+++ /dev/null
@@ -1,13 +0,0 @@
---- anal/lpc/makef.orig Tue Oct 8 15:53:00 2002
-+++ anal/lpc/makef Thu Apr 24 14:51:19 2003
-@@ -6,8 +6,8 @@
-
- OBJS = main.o $T/lpanal.o $T/lptrkfns.o $T/filopen.o $T/sfheader.o \
- $T/soundin.o $T/ulaw.o $T/aiff.o $T/wave.o $T/ieee80.o \
-- $T/memalloc.o $T/window.o $T/winFLTK.o $T/winascii.o $T/winEPS.o \
-- $T/aifc.o $T/getstring.o $T/FL_graph.o
-+ $T/memalloc.o $T/window.o $T/winascii.o $T/winEPS.o \
-+ $T/aifc.o $T/getstring.o
-
- lpcs: lpanal
-
diff --git a/audio/csound/files/patch-anal_pvoc_makef b/audio/csound/files/patch-anal_pvoc_makef
deleted file mode 100644
index 93bc1d64fa71..000000000000
--- a/audio/csound/files/patch-anal_pvoc_makef
+++ /dev/null
@@ -1,13 +0,0 @@
---- anal/pvoc/makef.orig Thu Apr 24 14:53:29 2003
-+++ anal/pvoc/makef Thu Apr 24 14:53:58 2003
-@@ -7,8 +7,8 @@
- OBJS = main.o $T/pvanal.o $T/pvxanal.o $T/pvfileio.o $T/filopen.o \
- $T/sfheader.o $T/mxfft.o \
- $T/soundin.o $T/ulaw.o $T/aiff.o $T/wave.o $T/ieee80.o $T/memalloc.o \
-- $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winFLTK.o $T/winascii.o \
-- $T/winEPS.o $T/aifc.o $T/getstring.o $T/FL_graph.o
-+ $T/pvoc.o $T/fft.o $T/dsputil.o $T/window.o $T/winascii.o \
-+ $T/winEPS.o $T/aifc.o $T/getstring.o
-
- pvocs: pvanal
-
diff --git a/audio/csound/files/patch-aops.c b/audio/csound/files/patch-aops.c
deleted file mode 100644
index 9f9622cbebf0..000000000000
--- a/audio/csound/files/patch-aops.c
+++ /dev/null
@@ -1,18 +0,0 @@
-$FreeBSD$
-
---- aops.c.orig Sun Jul 14 16:03:01 2002
-+++ aops.c Sun Jul 14 16:02:49 2002
-@@ -1,3 +1,4 @@
-+#include <sys/time.h>
- #include "cs.h" /* AOPS.C */
- #include "aops.h"
- #include <math.h>
-@@ -442,8 +443,6 @@ void ftsr(EVAL *p) /**** ft
- }
-
- #ifdef LINUX
--#include <sys/time.h>
--#include <unistd.h>
- void rtclock(EVAL *p)
- {
- struct timeval tv;
diff --git a/audio/csound/files/patch-cs_h b/audio/csound/files/patch-cs_h
deleted file mode 100644
index efd2baaf1a78..000000000000
--- a/audio/csound/files/patch-cs_h
+++ /dev/null
@@ -1,11 +0,0 @@
---- cs.h.orig Thu Apr 24 15:09:06 2003
-+++ cs.h Thu Apr 24 15:09:25 2003
-@@ -782,7 +782,7 @@
- # define POLL_EVENTS() STasks()
- # define __cdecl
- #else
--#ifdef LINUX
-+#if defined(LINUX) && defined(HAVE_FLTK)
- extern int POLL_EVENTS(void);
- #else
- # define POLL_EVENTS() (1)
diff --git a/audio/csound/files/patch-util1_cscore_makef b/audio/csound/files/patch-util1_cscore_makef
deleted file mode 100644
index 892198b6d6f7..000000000000
--- a/audio/csound/files/patch-util1_cscore_makef
+++ /dev/null
@@ -1,22 +0,0 @@
-$FreeBSD$
-
---- util1/cscore/makef.orig Sun Jul 14 16:02:58 2002
-+++ util1/cscore/makef Sun Jul 14 16:02:58 2002
-@@ -16,7 +16,7 @@ $I/cscore.h: $T/cscore.h
- cp $T/cscore.h $I
-
- cscore.a: $(OBJS)
-- -rm cscore.a
-+ -rm -f cscore.a
- ar q cscore.a $(OBJS)
- -ranlib cscore.a
-
-@@ -33,7 +33,7 @@ $T/memalloc.o:
-
-
- install: includes cscore.a
-- -rm $(LIB)/libcscore.a
-+ -rm -f $(LIB)/libcscore.a
- cp cscore.a $(LIB)/libcscore.a
-
- clean:
diff --git a/audio/csound/files/patch-util2_dnoise.dir_makef b/audio/csound/files/patch-util2_dnoise.dir_makef
deleted file mode 100644
index 4f5f2867adb0..000000000000
--- a/audio/csound/files/patch-util2_dnoise.dir_makef
+++ /dev/null
@@ -1,24 +0,0 @@
-$FreeBSD$
-
---- util2/dnoise.dir/makef.orig Sun Jul 14 16:02:59 2002
-+++ util2/dnoise.dir/makef Sun Jul 14 16:02:59 2002
-@@ -36,15 +36,15 @@ srconv: $(SOBJS)
-
- install: $(PROGS)
- -strip $(PROGS)
-- -rm $(DEST)/dnoise
-- -rm $(DEST)/srconv
-+ -rm -f $(DEST)/dnoise
-+ -rm -f $(DEST)/srconv
- cp $(PROGS) $(DEST)
-
- clean:
-- -rm $(COBS)
-+ -rm -f $(COBS)
-
- rmbak:
-- -rm *.bak *~
-+ -rm -f *.bak *~
-
- depend:
- gcc -M $(DEFINES) $(CSRCS) > deps
diff --git a/audio/csound/files/patch-util2_dnoise_dir_dnoise_c b/audio/csound/files/patch-util2_dnoise_dir_dnoise_c
deleted file mode 100644
index 1d0cc0900b89..000000000000
--- a/audio/csound/files/patch-util2_dnoise_dir_dnoise_c
+++ /dev/null
@@ -1,10 +0,0 @@
---- util2/dnoise.dir/dnoise.c.orig Thu Apr 24 15:16:01 2003
-+++ util2/dnoise.dir/dnoise.c Thu Apr 24 15:16:32 2003
-@@ -109,6 +109,7 @@
- static long bytes = 0;
- OPARMS O = {0,0, 0,1,1,0, 0,0, 0,0, 0,0, 1,0,0,7, 0,0,0, 0,0,0,0, 0,0 };
-
-+#undef POLL_EVENTS
- int POLL_EVENTS(void)
- {
- return 1;
diff --git a/audio/csound/files/patch-util2_dnoise_dir_srconv_c b/audio/csound/files/patch-util2_dnoise_dir_srconv_c
deleted file mode 100644
index afd9fc827ca8..000000000000
--- a/audio/csound/files/patch-util2_dnoise_dir_srconv_c
+++ /dev/null
@@ -1,10 +0,0 @@
---- util2/dnoise.dir/srconv.c.orig Thu Apr 24 15:17:43 2003
-+++ util2/dnoise.dir/srconv.c Thu Apr 24 15:18:07 2003
-@@ -78,6 +78,7 @@
- OPARMS O = {0,0, 0,1,1,0, 0,0, 0,0, 0,0, 1,0,0,7, 0,0,0, 0,0,0,0, 0,0 };
-
-
-+#undef POLL_EVENTS
- int POLL_EVENTS(void)
- {
- return 1;
diff --git a/audio/csound/files/pkg-message.in b/audio/csound/files/pkg-message.in
new file mode 100644
index 000000000000..99b492f26210
--- /dev/null
+++ b/audio/csound/files/pkg-message.in
@@ -0,0 +1,4 @@
+=====================================================================
+%%PREFIX%%/bin/mixer has been renamed to %%PREFIX%%/bin/cs_mixer so it
+won't conflict with /usr/bin/mixer
+=====================================================================
diff --git a/audio/csound/pkg-descr b/audio/csound/pkg-descr
index 5da9a0bccf7f..b1548f79b514 100644
--- a/audio/csound/pkg-descr
+++ b/audio/csound/pkg-descr
@@ -1,24 +1,19 @@
-from Martin Dupras' FAQ:
- Csound is a software synthesis package in the tradition of so-called
-music-N languages, among which the best-known is Music V. It consists of an
-orchestra- and score-driven executable, written in C for portability. Since
-Csound is a computational language, it is highly flexible and efficient;
-complexity is gained only at the expense of computation time. Basically Csound
-reads some files and creates the result as a file on disk or, on faster
-machines, through a DAC in real time.
- Csound needs at least two files to read from: the score, which is a
-kind of event list for scheduling events, and an orchestra which defines how
-Csound will synthesize those events. An orchestra is composed of instruments,
-which are basically processes triggered by the notes (events) in the score.
+Csound is a programming language designed and optimized for sound rendering and
+signal processing. The language consists of over 450 opcodes - the operational
+codes that the sound designer uses to build "instruments" or patches.
-WWW: http://mitpress.mit.edu/e-books/csound/frontpage.html
- http://mitpress.mit.edu/e-books/csound/fpage/FAQml/faq/faq.html
- http://music.dartmouth.edu/~dupras/wCsound/Csound.faq.html
- http://music.dartmouth.edu/~dupras/wCsound/csoundpage.html
- http://csounds.com/faq/index.html
- http://csounds.com/ezine/
- http://arcana.dartmouth.edu/~eric/
- http://www.werewolf.net/~hljmm/csound/articles/intro.html
- ftp://ftp.maths.bath.ac.uk/pub/dream/documentation/
+Although there are an increasing number of graphical "front-ends" for the
+language, you typically design and modify your patches using a word processor.
+Usually, you create two text files - a .orc (orchestra) file containing the
+"instruments," and a .sco (score) file containing the "notes."
-Trevor Johnson
+In Csound, the complexity of your patches is limited by your knowledge,
+interest, and need, but never by the language itself. For instance, a 22,050
+oscillator additive synthesizer with 1024 stage envelope generators on each is
+merely a copy-and-paste operation. The same goes for a 1 million voice
+granular texture!
+
+Have you ever dreamed of sounds such as these? Well in Csound you can. And in
+Csound these dreams can come true!
+
+WWW: http://csound.sourceforge.net/