aboutsummaryrefslogtreecommitdiffstats
path: root/audio/cueplayer
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-22 20:55:00 +0800
committermakc <makc@FreeBSD.org>2013-11-22 20:55:00 +0800
commit612bc3c9c8698b6a8cdbb965267678a0ac829218 (patch)
treeedc1328e7d68e649db202ae07c396b88869f73de /audio/cueplayer
parent83574ff9450fce1ff644a38992000262dfd6586b (diff)
downloadfreebsd-ports-gnome-612bc3c9c8698b6a8cdbb965267678a0ac829218.tar.gz
freebsd-ports-gnome-612bc3c9c8698b6a8cdbb965267678a0ac829218.tar.zst
freebsd-ports-gnome-612bc3c9c8698b6a8cdbb965267678a0ac829218.zip
- Convert to USES=qmake (and other USES while I'm here)
- Add state support - Convert LIB_DEPENDS to new style, adjust USE_QT4 components, etc. Approved by: portmgr (blanket approval)
Diffstat (limited to 'audio/cueplayer')
-rw-r--r--audio/cueplayer/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/audio/cueplayer/Makefile b/audio/cueplayer/Makefile
index d1f0ef5d7a6b..74d57f6140c4 100644
--- a/audio/cueplayer/Makefile
+++ b/audio/cueplayer/Makefile
@@ -10,18 +10,17 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= vg@FreeBSD.org
COMMENT= CUE player
-LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
-USES= pkgconfig
-NO_STAGE= yes
-USE_QT4= gui xml qmake_build uic_build moc_build rcc_build network
+USES= pkgconfig qmake
+USE_QT4= gui xml uic_build moc_build rcc_build network
USE_GSTREAMER= flac good dvd lame ugly ffmpeg taglib ogg vorbis soup libmms wavpack
LICENSE= GPLv3
DESKTOP_ENTRIES="Cueplayer" "Lightweight media player based on Qt and Gstreamer" \
"${DATADIR}/${PORTNAME}.png" "${PORTNAME}" \
- "AudioVideo;Audio;Video;" ${FALSE}
+ "AudioVideo;Audio;Video;" true
post-patch:
cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,/usr/share/cueplayer/,${DATADIR}/,g' \
@@ -29,10 +28,7 @@ post-patch:
${REINPLACE_CMD} -e 's,/usr/share,${PREFIX},g' \
${WRKSRC}/${PORTNAME}.pro
-do-configure:
- cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX}
-
post-install:
- ${INSTALL_DATA} ${WRKSRC}/images/${PORTNAME}.png ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/images/${PORTNAME}.png ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>