aboutsummaryrefslogtreecommitdiffstats
path: root/audio/darkice/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-08-13 05:01:56 +0800
committernaddy <naddy@FreeBSD.org>2002-08-13 05:01:56 +0800
commit1f753e24503ec6ff4caa3d16d8cb88d801d925a6 (patch)
tree847e9f4ba6e6372b24250265e00148cbb75016f5 /audio/darkice/Makefile
parentd6bc8b71cd009d4198d1d4a536f6e0b690d582db (diff)
downloadfreebsd-ports-gnome-1f753e24503ec6ff4caa3d16d8cb88d801d925a6.tar.gz
freebsd-ports-gnome-1f753e24503ec6ff4caa3d16d8cb88d801d925a6.tar.zst
freebsd-ports-gnome-1f753e24503ec6ff4caa3d16d8cb88d801d925a6.zip
Update to 0.10.1.
PR: 41499 Submitted by: Ports Fury
Diffstat (limited to 'audio/darkice/Makefile')
-rw-r--r--audio/darkice/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index ce398e0b2407..050ac285734c 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -7,22 +7,32 @@
#
PORTNAME= darkice
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.10.1
CATEGORIES= audio net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame-devel \
+LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
vorbis.2:${PORTSDIR}/audio/libvorbis
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-lame-prefix=${LOCALBASE} \
--with-vorbis-prefix=${LOCALBASE}
MAN1= darkice.1
MAN5= darkice.cfg.5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+CXXFLAGS:= ${CXXFLAGS:N-O*}
+.endif
+
+# alternatively:
+#
+#USE_GCC= 3.1
+
+.include <bsd.port.post.mk>