aboutsummaryrefslogtreecommitdiffstats
path: root/audio/darkice/files
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-04-16 01:49:42 +0800
committerflz <flz@FreeBSD.org>2005-04-16 01:49:42 +0800
commit23b779a7dc3d8b273d4377ddeebdf7b9a83032ad (patch)
tree87503c2e8500ece4c142f1800842cabcc43a655c /audio/darkice/files
parentd94fdcc4ed9106e74d62b0ecec1cd867f75d891e (diff)
downloadfreebsd-ports-gnome-23b779a7dc3d8b273d4377ddeebdf7b9a83032ad.tar.gz
freebsd-ports-gnome-23b779a7dc3d8b273d4377ddeebdf7b9a83032ad.tar.zst
freebsd-ports-gnome-23b779a7dc3d8b273d4377ddeebdf7b9a83032ad.zip
- Update to 0.15.
PR: ports/79970 Submitted by: Ports Fury
Diffstat (limited to 'audio/darkice/files')
-rw-r--r--audio/darkice/files/patch-src_JackDspSource.cpp32
-rw-r--r--audio/darkice/files/patch-src_Makefile.in14
-rw-r--r--audio/darkice/files/patch-src_OssDspSource.cpp16
3 files changed, 32 insertions, 30 deletions
diff --git a/audio/darkice/files/patch-src_JackDspSource.cpp b/audio/darkice/files/patch-src_JackDspSource.cpp
new file mode 100644
index 000000000000..6e0035d1a1b1
--- /dev/null
+++ b/audio/darkice/files/patch-src_JackDspSource.cpp
@@ -0,0 +1,32 @@
+--- src/JackDspSource.cpp.orig Mon Apr 4 17:36:17 2005
++++ src/JackDspSource.cpp Fri Apr 15 04:15:23 2005
+@@ -38,6 +38,18 @@
+ #include "config.h"
+ #endif
+
++#ifdef HAVE_STDIO_H
++#include <stdio.h>
++#else
++#error need stdio.h
++#endif
++
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#else
++#error need stdlib.h
++#endif
++
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #else
+@@ -60,6 +72,10 @@
+ #include <math.h>
+ #else
+ #error need math.h
++#endif
++
++#ifdef __FreeBSD__
++#define lrintf(x) rintf(x)
+ #endif
+
+ #include "Util.h"
diff --git a/audio/darkice/files/patch-src_Makefile.in b/audio/darkice/files/patch-src_Makefile.in
deleted file mode 100644
index b42463d0041f..000000000000
--- a/audio/darkice/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/Makefile.in.orig Mon Feb 16 07:33:35 2004
-+++ src/Makefile.in Mon Feb 16 18:28:54 2004
-@@ -80,7 +80,7 @@
- am__quote = @am__quote@
- install_sh = @install_sh@
- bin_PROGRAMS = darkice
--CXXFLAGS = -O2 -pedantic -Wall @DEBUG_CXXFLAGS@ @PTHREAD_CFLAGS@
-+CXXFLAGS = @CXXFLAGS@ @DEBUG_CXXFLAGS@ @PTHREAD_CFLAGS@
- INCLUDES = @LAME_INCFLAGS@ @VORBIS_INCFLAGS@ @ALSA_INCFLAGS@
- LDADD = @PTHREAD_LIBS@ @LAME_LDFLAGS@ @VORBIS_LDFLAGS@ @ALSA_LDFLAGS@
-
diff --git a/audio/darkice/files/patch-src_OssDspSource.cpp b/audio/darkice/files/patch-src_OssDspSource.cpp
deleted file mode 100644
index 18a73398bf2e..000000000000
--- a/audio/darkice/files/patch-src_OssDspSource.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/OssDspSource.cpp.orig Thu Feb 13 00:48:22 2003
-+++ src/OssDspSource.cpp Thu Jan 8 12:15:07 2004
-@@ -86,6 +86,13 @@
- #error need sys/soundcard.h
- #endif
-
-+#if !defined(AFMT_S16_NE)
-+#if defined(BYTE_ORDER) && (BYTE_ORDER == BIG_ENDIAN)
-+#define AFMT_S16_NE AFMT_S16_BE
-+#else
-+#define AFMT_S16_NE AFMT_S16_LE
-+#endif
-+#endif
-
- #include "Util.h"
- #include "Exception.h"