aboutsummaryrefslogtreecommitdiffstats
path: root/audio/deadbeef/files
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2014-07-31 01:51:18 +0800
committervg <vg@FreeBSD.org>2014-07-31 01:51:18 +0800
commit1434b5a1a10c5fefc8dabcaedfa74285cf4360ff (patch)
treeb1aa1dbc1caae79f6e2888fc690124572ca0824d /audio/deadbeef/files
parent18f6d9e8df7127729669418a084b269fdf9ae3b5 (diff)
downloadfreebsd-ports-gnome-1434b5a1a10c5fefc8dabcaedfa74285cf4360ff.tar.gz
freebsd-ports-gnome-1434b5a1a10c5fefc8dabcaedfa74285cf4360ff.tar.zst
freebsd-ports-gnome-1434b5a1a10c5fefc8dabcaedfa74285cf4360ff.zip
- Upgrade to 0.6.2-rc4
Diffstat (limited to 'audio/deadbeef/files')
-rw-r--r--audio/deadbeef/files/patch-fft.c13
-rw-r--r--audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in12
-rw-r--r--audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c32
3 files changed, 45 insertions, 12 deletions
diff --git a/audio/deadbeef/files/patch-fft.c b/audio/deadbeef/files/patch-fft.c
new file mode 100644
index 000000000000..d68f37406591
--- /dev/null
+++ b/audio/deadbeef/files/patch-fft.c
@@ -0,0 +1,13 @@
+--- fft.c.orig 2014-02-24 13:56:57.244236013 +0400
++++ fft.c 2014-02-24 13:57:16.293650674 +0400
+@@ -27,6 +27,10 @@
+ #include <math.h>
+ #include <complex.h>
+
++#if __FreeBSD_version < 902000
++# define cexpf(x) (expf(crealf(x))*(cosf(cimagf(x))+sinf(cimagf(x))*I))
++#endif
++
+ #define N (DDB_FREQ_BANDS * 2)
+
+ static float hamming[N]; /* hamming window, scaled to sum to 1 */
diff --git a/audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in b/audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in
index c225d1f19074..44008e5fe44b 100644
--- a/audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in
+++ b/audio/deadbeef/files/patch-plugins-ffmpeg-Makefile.in
@@ -1,15 +1,17 @@
---- plugins/ffmpeg/Makefile.in.orig 2013-10-08 19:57:17.298159051 -0300
-+++ plugins/ffmpeg/Makefile.in 2013-10-08 19:57:32.774264065 -0300
-@@ -108,11 +108,11 @@
+--- plugins/ffmpeg/Makefile.in.orig 2014-06-28 23:22:55.232212539 +0400
++++ plugins/ffmpeg/Makefile.in 2014-06-28 23:31:19.076178566 +0400
+@@ -166,11 +166,11 @@
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
am__mv = mv -f
-COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+COMPILE = $(CC) $(DEFS) $(AM_CFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
- LTCOMPILE = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
- $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) \
+-LTCOMPILE = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
+- $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) \
- $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
++LTCOMPILE = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
++ --mode=compile $(CC) $(DEFS) \
+ $(AM_CFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(CFLAGS)
AM_V_CC = $(am__v_CC_@AM_V@)
diff --git a/audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c b/audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c
index 5f3c4dad926c..187bfc25ddf3 100644
--- a/audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c
+++ b/audio/deadbeef/files/patch-plugins-ffmpeg-ffmpeg.c
@@ -1,8 +1,8 @@
---- plugins/ffmpeg/ffmpeg.c.orig 2013-10-08 19:54:33.943158658 -0300
-+++ plugins/ffmpeg/ffmpeg.c 2013-10-08 19:54:44.352159132 -0300
-@@ -25,20 +25,11 @@
-
+--- plugins/ffmpeg/ffmpeg.c.orig 2014-01-28 01:24:09.000000000 +0400
++++ plugins/ffmpeg/ffmpeg.c 2014-02-23 16:32:57.108250350 +0400
+@@ -26,20 +26,11 @@
#include "../../deadbeef.h"
+ #include "../../strdupa.h"
-#if !FFMPEG_OLD
-
@@ -21,12 +21,30 @@
#define AVERROR_EOF AVERROR(EPIPE)
#if LIBAVFORMAT_VERSION_MAJOR < 53
-@@ -49,8 +40,6 @@
+@@ -50,8 +41,6 @@
#define AV_VERSION_INT(a, b, c) (a<<16 | b<<8 | c)
#endif
-#endif
-
- //#define trace(...) { fprintf(stderr, __VA_ARGS__); }
- #define trace(fmt,...)
+ #if LIBAVFORMAT_VERSION_INT >= AV_VERSION_INT(54, 6, 0)
+ #define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000
+ #define av_find_stream_info(ctx) avformat_find_stream_info(ctx,NULL)
+@@ -239,7 +228,7 @@ ffmpeg_init (DB_fileinfo_t *_info, DB_pl
+ _info->fmt.bps = bps;
+ _info->fmt.channels = info->ctx->channels;
+ _info->fmt.samplerate = samplerate;
+- if (info->ctx->sample_fmt == AV_SAMPLE_FMT_FLT || info->ctx->sample_fmt == AV_SAMPLE_FMT_FLTP) {
++ if (info->ctx->sample_fmt == AV_SAMPLE_FMT_FLT) {
+ _info->fmt.is_float = 1;
+ }
+
+@@ -307,7 +296,7 @@ ffmpeg_read (DB_fileinfo_t *_info, char
+ _info->fmt.channels = info->ctx->channels;
+ _info->fmt.samplerate = info->ctx->sample_rate;
+ _info->fmt.bps = av_get_bits_per_sample_format (info->ctx->sample_fmt);
+- _info->fmt.is_float = (info->ctx->sample_fmt == AV_SAMPLE_FMT_FLT || info->ctx->sample_fmt == AV_SAMPLE_FMT_FLTP);
++ _info->fmt.is_float = (info->ctx->sample_fmt == AV_SAMPLE_FMT_FLT);
+
+ int samplesize = _info->fmt.channels * _info->fmt.bps / 8;