aboutsummaryrefslogtreecommitdiffstats
path: root/audio/denemo/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
commit971087c2b4d6b0b917e3fac3ac1334b04f7c9907 (patch)
tree7181a8316bbb1b7be4386d9173b3c6ace07025da /audio/denemo/Makefile
parent0cc85c09b55a7d94ca1d7c16c8eedae091f2840c (diff)
downloadfreebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.gz
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.zst
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Diffstat (limited to 'audio/denemo/Makefile')
-rw-r--r--audio/denemo/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index 93d0ed8a945c..1ef885658adf 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= denemo
PORTVERSION= 0.5.9
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,10 +15,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= trevor@FreeBSD.org
COMMENT= Graphical score editor
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- intl.4:${PORTSDIR}/devel/gettext \
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
xml.5:${PORTSDIR}/textproc/libxml
+USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
PLIST= ${WRKDIR}/pkg-plist
SHARED= denemo.conf denemo.keymaprc english.keymaprc french.keymaprc
@@ -29,11 +30,10 @@ USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
+BROKEN= "Does not compile"
.endif
post-configure:
- ${PERL} -pi -e "s:module12:module12 -lgnugetopt:g" ${WRKSRC}/Makefile
${PERL} -pi -e "s:<wait.h:<sys/wait.h:g" ${WRKSRC}/*.c
pre-install: