aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ecasound
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-06 13:38:13 +0800
committerrafan <rafan@FreeBSD.org>2006-08-06 13:38:13 +0800
commitd05efdcf3e371adf7151b8df15dce6eef1218362 (patch)
tree4353ed76b61330528d97e309076ca8dd1c484ee2 /audio/ecasound
parentbdf59c0f1dc6047a2f6bcd2c04f3eed5d3f2a351 (diff)
downloadfreebsd-ports-gnome-d05efdcf3e371adf7151b8df15dce6eef1218362.tar.gz
freebsd-ports-gnome-d05efdcf3e371adf7151b8df15dce6eef1218362.tar.zst
freebsd-ports-gnome-d05efdcf3e371adf7151b8df15dce6eef1218362.zip
- Depend on readline port if library exists
program will link it rather than a system one PR: ports/101437 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'audio/ecasound')
-rw-r--r--audio/ecasound/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
index 731211c1e0e5..f04a9c635aef 100644
--- a/audio/ecasound/Makefile
+++ b/audio/ecasound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ecasound
PORTVERSION= 2.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://ecasound.seul.org/download/
@@ -16,7 +16,7 @@ COMMENT= Multitrack audio processing software
USE_GNOME= gnometarget
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-pyecasound --disable-rubyecasound --with-largefile \
--enable-sys-readline
@@ -32,8 +32,11 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
+.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.endif
+
+.if ${OSVERSION} < 500000
CFLAGS+= -fpermissive
.endif