aboutsummaryrefslogtreecommitdiffstats
path: root/audio/esound
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
committermarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
commit6d8ed8f7c7511223163de715a97ffc04bf6fada9 (patch)
tree40dc015efe383243b0880df377f73ee250da7de7 /audio/esound
parentc7f342a8d7b82e85b9625c4403600fc20ce41da6 (diff)
downloadfreebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.gz
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.zst
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Diffstat (limited to 'audio/esound')
-rw-r--r--audio/esound/Makefile3
-rw-r--r--audio/esound/distinfo6
-rw-r--r--audio/esound/files/patch-ad23
-rw-r--r--audio/esound/files/patch-esddsp.c22
4 files changed, 31 insertions, 23 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index 8f0f1e4735b3..71c50a2fd1fd 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -3,10 +3,11 @@
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/audio/esound/Makefile,v 1.1 2008/11/20 19:38:24 marcus Exp $
#
PORTNAME= esound
-PORTVERSION= 0.2.40
+PORTVERSION= 0.2.41
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.2
diff --git a/audio/esound/distinfo b/audio/esound/distinfo
index 571cce564ad1..d33ab14b52c7 100644
--- a/audio/esound/distinfo
+++ b/audio/esound/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome/esound-0.2.40.tar.bz2) = e9009889ab81269f3021ebcad8addb96
-SHA256 (gnome/esound-0.2.40.tar.bz2) = 74b6d9f3dd68ee0b8d95d4d2c78cbd913807cb6c0739d05d8dd75a73fc84d4a7
-SIZE (gnome/esound-0.2.40.tar.bz2) = 423798
+MD5 (gnome/esound-0.2.41.tar.bz2) = 8d9aad3d94d15e0d59ba9dc0ea990c6c
+SHA256 (gnome/esound-0.2.41.tar.bz2) = 5eb5dd29a64b3462a29a5b20652aba7aa926742cef43577bf0796b787ca34911
+SIZE (gnome/esound-0.2.41.tar.bz2) = 396474
diff --git a/audio/esound/files/patch-ad b/audio/esound/files/patch-ad
index c2059f5d0703..68018a173ede 100644
--- a/audio/esound/files/patch-ad
+++ b/audio/esound/files/patch-ad
@@ -1,5 +1,5 @@
---- esdlib.c.orig 2008-07-30 17:08:59.000000000 -0400
-+++ esdlib.c 2008-09-07 22:19:48.000000000 -0400
+--- esdlib.c.orig 2008-11-18 15:35:19.000000000 -0500
++++ esdlib.c 2008-11-20 14:32:59.000000000 -0500
@@ -21,6 +21,8 @@
#include <errno.h>
#include <sys/wait.h>
@@ -9,17 +9,16 @@
#include <sys/un.h>
-@@ -895,8 +897,7 @@ int esd_open_sound( const char *host )
- setsid();
- cmd = malloc(strlen(SERVERDIR"/esd -spawnfd 999999") + (esd_spawn_options?strlen(esd_spawn_options):0));
+@@ -928,7 +930,7 @@ int esd_open_sound( const char *rhost )
+ putenv(preload2);
+ }
+ cmd = malloc(strlen(SERVERDIR"/esd -spawnfd 9999999999") + strlen(esd_spawn_options));
+- sprintf(cmd, "%s/esd %s -spawnfd %d", SERVERDIR, esd_spawn_options, esd_pipe[1]);
++ sprintf(cmd, "exec esd %s -spawnfd %d", esd_spawn_options?esd_spawn_options:"", esd_pipe[1]);
-- sprintf(cmd, "%s/esd %s -spawnfd %d", SERVERDIR, esd_spawn_options?esd_spawn_options:"", esd_pipe[1]);
--
-+ sprintf(cmd, "exec esd %s -spawnfd %d", esd_spawn_options?esd_spawn_options:"", esd_pipe[1]);
- execl("/bin/sh", "/bin/sh", "-c", cmd, NULL);
- perror("execl");
- _exit(1);
-@@ -1709,3 +1710,34 @@ int esd_close( int esd )
+ if(!fork()) {
+ /* child of child process. Minimal so startup overhead is
+@@ -1747,3 +1749,34 @@ int esd_close( int esd )
return close( esd );
}
diff --git a/audio/esound/files/patch-esddsp.c b/audio/esound/files/patch-esddsp.c
index 3ea9a1c61369..3c24fc97e477 100644
--- a/audio/esound/files/patch-esddsp.c
+++ b/audio/esound/files/patch-esddsp.c
@@ -1,6 +1,14 @@
---- esddsp.c.orig 2008-07-15 11:47:20.000000000 -0400
-+++ esddsp.c 2008-07-17 13:58:09.000000000 -0400
-@@ -220,16 +220,19 @@ open_wrapper (int (*func) (const char *,
+--- esddsp.c.orig 2008-11-18 15:35:19.000000000 -0500
++++ esddsp.c 2008-11-20 14:35:02.000000000 -0500
+@@ -70,6 +70,7 @@
+
+ #if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__bsdi__)
+ typedef unsigned long request_t;
++typedef off_t off64_t;
+ #else
+ typedef int request_t;
+ #endif
+@@ -228,16 +229,19 @@ open_wrapper (int (*func) (const char *,
const char *pathname, int flags, ...)
{
va_list args;
@@ -25,7 +33,7 @@
if (!strcmp (pathname, "/dev/dsp"))
{
-@@ -260,7 +263,7 @@ open (const char *pathname, int flags, .
+@@ -268,7 +272,7 @@ open (const char *pathname, int flags, .
{
static int (*func) (const char *, int, mode_t) = NULL;
va_list args;
@@ -34,7 +42,7 @@
DPRINTF ("open\n");
-@@ -275,9 +278,12 @@ open (const char *pathname, int flags, .
+@@ -283,9 +287,12 @@ open (const char *pathname, int flags, .
}
}
@@ -50,7 +58,7 @@
return open_wrapper(func, pathname, flags, mode);
}
-@@ -287,7 +293,7 @@ open64 (const char *pathname, int flags,
+@@ -295,7 +302,7 @@ open64 (const char *pathname, int flags,
{
static int (*func) (const char *, int, mode_t) = NULL;
va_list args;
@@ -59,7 +67,7 @@
DPRINTF ("open64\n");
-@@ -302,9 +308,12 @@ open64 (const char *pathname, int flags,
+@@ -310,9 +317,12 @@ open64 (const char *pathname, int flags,
}
}