aboutsummaryrefslogtreecommitdiffstats
path: root/audio/esound
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-08-17 13:23:07 +0800
committermezz <mezz@FreeBSD.org>2004-08-17 13:23:07 +0800
commit9bef5896cf6285abc1fd84f0ab218473b8c31456 (patch)
treef94884fff903d187df2ac29281ed23727e1095c6 /audio/esound
parentd8ee31e98d54ba6c5b5c50a1cbfb061c185350ae (diff)
downloadfreebsd-ports-gnome-9bef5896cf6285abc1fd84f0ab218473b8c31456.tar.gz
freebsd-ports-gnome-9bef5896cf6285abc1fd84f0ab218473b8c31456.tar.zst
freebsd-ports-gnome-9bef5896cf6285abc1fd84f0ab218473b8c31456.zip
- Respect the esd.conf and add est.conf.default. [1]
- Remove the patch-configure; it's no longer need. - Make the portlint a happy man. PR: ports/69175 [1] Reported by: Torfinn Ingolfsen <tingo@start.no> [1]
Diffstat (limited to 'audio/esound')
-rw-r--r--audio/esound/Makefile20
-rw-r--r--audio/esound/files/patch-configure13
-rw-r--r--audio/esound/pkg-plist4
3 files changed, 20 insertions, 17 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index 8c09f9fafb37..d94f8666d479 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -7,6 +7,7 @@
PORTNAME= esound
PORTVERSION= 0.2.35
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.2
@@ -17,15 +18,28 @@ COMMENT= A sound library for enlightenment package
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
-USE_GETOPT_LONG= yes
USE_BZIP2= yes
-INSTALLS_SHLIB= yes
USE_GNOME= gnometarget gnomehack
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
+USE_GETOPT_LONG=yes
-CONFLICTS= py*-ro-*
+CONFLICTS= py*-ro-[0-9]*
MAN1= esd-config.1 esd.1 esdcat.1 esdctl.1 esddsp.1 esdfilt.1 esdloop.1 \
esdmon.1 esdplay.1 esdrec.1 esdsample.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|esdconf_DATA = esd.conf|esdconf_DATA = |g' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ if [ ! -f ${PREFIX}/etc/esd.conf ]; then \
+ ${INSTALL_DATA} ${WRKSRC}/esd.conf ${PREFIX}/etc/esd.conf; \
+ ${INSTALL_DATA} ${WRKSRC}/esd.conf ${PREFIX}/etc/esd.conf.default; \
+ else \
+ ${INSTALL_DATA} ${WRKSRC}/esd.conf ${PREFIX}/etc/esd.conf.default; \
+ fi
+
.include <bsd.port.mk>
diff --git a/audio/esound/files/patch-configure b/audio/esound/files/patch-configure
deleted file mode 100644
index 31b690366f87..000000000000
--- a/audio/esound/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- configure 2002/05/07 06:39:43 1.1
-+++ configure 2002/05/07 06:39:55
-@@ -5308,6 +5308,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/esound/pkg-plist b/audio/esound/pkg-plist
index 6617f3009ab9..abff241079d2 100644
--- a/audio/esound/pkg-plist
+++ b/audio/esound/pkg-plist
@@ -9,7 +9,9 @@ bin/esdmon
bin/esdplay
bin/esdrec
bin/esdsample
-etc/esd.conf
+@unexec if cmp -s %D/etc/esd.conf %D/etc/esd.conf.default; then rm -f %D/etc/esd.conf; fi
+etc/esd.conf.default
+@exec [ -f %B/esd.conf ] || cp %B/%f %B/esd.conf
include/esd.h
lib/libesd.a
lib/libesd.so