aboutsummaryrefslogtreecommitdiffstats
path: root/audio/esound
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-11 20:55:44 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-11 20:55:44 +0800
commit7cbb09e8ab50b07b76441d7d38d31704668cbd8c (patch)
tree0524b57673a0b89de52eb47f1945cb28b0ca60e5 /audio/esound
parent30b4c0415036b190df241ae36cc768137ea65ec1 (diff)
downloadfreebsd-ports-gnome-7cbb09e8ab50b07b76441d7d38d31704668cbd8c.tar.gz
freebsd-ports-gnome-7cbb09e8ab50b07b76441d7d38d31704668cbd8c.tar.zst
freebsd-ports-gnome-7cbb09e8ab50b07b76441d7d38d31704668cbd8c.zip
Put back gugetopt dependency taken out by marcus. The reason the dependency
is here is to prevent gettext from rolling its own version of getopt_long into the binary, thereby slightly improving code sharing.
Diffstat (limited to 'audio/esound')
-rw-r--r--audio/esound/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index b6f01a744d59..fe6493c6b6d2 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= esound
PORTVERSION= 0.2.26
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/esound
@@ -15,13 +15,14 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_BZIP2= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.mk>