aboutsummaryrefslogtreecommitdiffstats
path: root/audio/exaile-devel/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-12-19 16:06:33 +0800
committersat <sat@FreeBSD.org>2006-12-19 16:06:33 +0800
commit313bde6d2cbdd8c7c79558b4d78e72ce45e8e94f (patch)
tree30efbd82fdbc35177cda69439d55c1417dff8beb /audio/exaile-devel/Makefile
parent7b4319fbe15c3a1929531f3cd42002c08c3ecd87 (diff)
downloadfreebsd-ports-gnome-313bde6d2cbdd8c7c79558b4d78e72ce45e8e94f.tar.gz
freebsd-ports-gnome-313bde6d2cbdd8c7c79558b4d78e72ce45e8e94f.tar.zst
freebsd-ports-gnome-313bde6d2cbdd8c7c79558b4d78e72ce45e8e94f.zip
Add port audio/exaile:
Exaile is a media player aiming to be similar to KDE's AmaroK, but for GTK+. It incorporates many of the cool things from AmaroK (and other media players) like automatic fetching of album art, handling of large libraries, lyrics fetching, artist/album information via the wikipedia, last.fm support, optional iPod support (assuming you have python-gpod installed). WWW: http://www.exaile.org/ Author: Adam Olsen <arolsen@gmail.com>
Diffstat (limited to 'audio/exaile-devel/Makefile')
-rw-r--r--audio/exaile-devel/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/audio/exaile-devel/Makefile b/audio/exaile-devel/Makefile
new file mode 100644
index 000000000000..dd95267882c3
--- /dev/null
+++ b/audio/exaile-devel/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: exaile
+# Date created: 19 December 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exaile
+DISTVERSION= 0.2.7b2
+CATEGORIES= audio
+MASTER_SITES= http://www.exaile.org/files/ CSME
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= AmaroK replacement for GTK+
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus \
+ ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
+
+USE_GNOME= pygtk2
+USE_GSTREAMER= python
+USE_PYTHON= yes
+PLIST_FILES= share/applications/${PORTNAME}.desktop share/pixmaps/${PORTNAME}.png bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^PREFIX/d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^PYTHON_DIR/s|=.*|=${PYTHON_INCLUDEDIR}|' ${WRKSRC}/mmkeys/Makefile
+
+create-plist:
+ ${FIND} -s ${DATADIR} -not -type d|${SED} -e 's|^${DATADIR}|%%DATADIR%%|' > ${PLIST}
+ ${FIND} -ds ${DATADIR} -type d|${SED} -e 's|^${DATADIR}|%%DATADIR%%|' \
+ -e 's|^|@dirrm |' >> ${PLIST}
+ @${ECHO_CMD} '@dirrmtry share/applications' >> ${PLIST}
+ @${ECHO_CMD} '@dirrmtry share/pixmaps' >> ${PLIST}
+
+.include <bsd.port.mk>