aboutsummaryrefslogtreecommitdiffstats
path: root/audio/fdmf
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-17 01:58:47 +0800
committerantoine <antoine@FreeBSD.org>2014-01-17 01:58:47 +0800
commita297c489b3026dc56c3b4a4f486c1d9ddf511255 (patch)
tree3e993df5b90f8fea59341eba6ccda989e517ae08 /audio/fdmf
parent71aac99f7c0b15fae35dc550a218c478c650e88d (diff)
downloadfreebsd-ports-gnome-a297c489b3026dc56c3b4a4f486c1d9ddf511255.tar.gz
freebsd-ports-gnome-a297c489b3026dc56c3b4a4f486c1d9ddf511255.tar.zst
freebsd-ports-gnome-a297c489b3026dc56c3b4a4f486c1d9ddf511255.zip
- Stage support
- Shebangfix scripts - Bump PORTREVISION
Diffstat (limited to 'audio/fdmf')
-rw-r--r--audio/fdmf/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/audio/fdmf/Makefile b/audio/fdmf/Makefile
index e612b62e263b..8905926ec6cb 100644
--- a/audio/fdmf/Makefile
+++ b/audio/fdmf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fdmf
DISTVERSION= 0.0.9s
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://w140.com/audio/ CENKES
@@ -18,8 +18,8 @@ RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
ogg123:${PORTSDIR}/audio/vorbis-tools \
p5-GDBM>=0:${PORTSDIR}/databases/p5-GDBM
-USES= perl5
-NO_STAGE= yes
+USES= perl5 shebangfix
+SHEBANG_FILES= ${SCRS}
CFLAGS= -I${LOCALBASE}/include -L. -L${LOCALBASE}/lib
MAKE_ENV= VPATH=common
PORTDOCS= README
@@ -27,17 +27,15 @@ BINS= sonic_reducer vector_pairs
SCRS= ${PORTNAME} ${PORTNAME}_bench cleanup_dups optparam
PLIST_FILES= ${BINS:S,^,bin/,} ${SCRS:S,^,bin/,}
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -Ee '/^(CFLAGS|CC) =/s|.*||' -e 's|common/||g' ${WRKSRC}/Makefile
do-install:
- @${INSTALL_PROGRAM} ${BINS:S,^,${WRKSRC}/,} ${PREFIX}/bin/
- @${INSTALL_SCRIPT} ${SCRS:S,^,${WRKSRC}/,} ${PREFIX}/bin/
-.if ${PORT_OPTIONS:MDOCS}
- @${INSTALL} -d ${DOCSDIR}/
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
-.endif
+ ${INSTALL_PROGRAM} ${BINS:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${SCRS:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>