aboutsummaryrefslogtreecommitdiffstats
path: root/audio/festvox-aec/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-05 09:23:00 +0800
committertrevor <trevor@FreeBSD.org>2003-11-05 09:23:00 +0800
commitf914cc51bf23a97f171483a65cf55242e7e29c8f (patch)
tree88a3bc4bdc129f70b573edab823554d59c302e97 /audio/festvox-aec/Makefile
parent0747ab62298f74114b445c2bf0468cb534e50a10 (diff)
downloadfreebsd-ports-gnome-f914cc51bf23a97f171483a65cf55242e7e29c8f.tar.gz
freebsd-ports-gnome-f914cc51bf23a97f171483a65cf55242e7e29c8f.tar.zst
freebsd-ports-gnome-f914cc51bf23a97f171483a65cf55242e7e29c8f.zip
Add port of the "aec" American male voice, for Festival with the
OGI extensions. I prepared this in June of 2000 but just noticed now that it had not been committed. Obtained from: NetBSD pkgsrc/audio/festvox-aec
Diffstat (limited to 'audio/festvox-aec/Makefile')
-rw-r--r--audio/festvox-aec/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/audio/festvox-aec/Makefile b/audio/festvox-aec/Makefile
new file mode 100644
index 000000000000..828f230843fd
--- /dev/null
+++ b/audio/festvox-aec/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: festvox-aec
+# Date created: 2000-06-12
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $NetBSD: Makefile,v 1.16 2003/04/10 01:28:05 grant Exp $
+# $FreeBSD$
+#
+
+PORTNAME= festvox_aec
+PORTVERSION= 2.0
+CATEGORIES= audio accessibility
+MASTER_SITES= ${MASTER_SITE_FESTIVAL_OGI}
+DISTNAME= voice_aec_di-2.0
+DIST_SUBDIR= festival
+
+MAINTAINER= trevor@jpj.net
+COMMENT= American English male voice for Festival speech synthesis system
+
+RUN_DEPENDS= festival:${PORTSDIR}/audio/festival \
+ ${LOCALBASE}/share/festival/lib/dicts/ogi_lex.out:${PORTSDIR}/audio/festlex-ogi
+
+AECDIR= share/festival/lib/voices/english/aec_diphone
+FHOME= ${PREFIX}/share/festival
+NO_BUILD= y
+PLIST= ${WRKDIR}/plist
+RESTRICTED= "no commercial use"
+WRKSRC= ${WRKDIR}/festival
+
+post-extract:
+ ${CHMOD} -R a+r ${WRKSRC}
+ ${FIND} ${WRKSRC} -type d -print0 | ${XARGS} ${CHMOD} 755
+ ${FIND} ${WRKSRC} -type d -name CVS | ${XARGS} ${RM} -fr
+
+pre-install:
+ ${RM} -f ${PLIST}
+.for ii in _diphone.scm diph.msec gain.dat
+ ${ECHO_CMD} ${AECDIR}/festvox/aec${ii} >> ${PLIST}
+.endfor
+ ${ECHO_CMD} ${AECDIR}/group/aec_di_resLPC.group >> ${PLIST}
+.for ii in /group /festvox /
+ ${ECHO_CMD} @dirrm ${AECDIR}${ii} >> ${PLIST}
+.endfor
+
+do-install:
+ ${MKDIR} ${FHOME}
+ cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+
+.include <bsd.port.mk>