aboutsummaryrefslogtreecommitdiffstats
path: root/audio/firefly
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /audio/firefly
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'audio/firefly')
-rw-r--r--audio/firefly/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index 4f8d7575d749..c8065cce1aef 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -26,10 +26,10 @@ LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
CONFLICTS= mt-daapd-0.2.*
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS+="${PTHREAD_CFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CFLAGS+= ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --prefix=${PREFIX} --with-id3tag=${PREFIX} \
--enable-sqlite3 --enable-oggvorbis --enable-flac