aboutsummaryrefslogtreecommitdiffstats
path: root/audio/flac/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-04-16 07:38:24 +0800
committernaddy <naddy@FreeBSD.org>2003-04-16 07:38:24 +0800
commit05705cb0329336f63e44780e1d3fd52e6c2e3eab (patch)
tree01d16161e696cbe85c5899cc8022643d27751623 /audio/flac/Makefile
parentc2d6daf25a7dd215e46c7d86eacf5acfbff290bf (diff)
downloadfreebsd-ports-gnome-05705cb0329336f63e44780e1d3fd52e6c2e3eab.tar.gz
freebsd-ports-gnome-05705cb0329336f63e44780e1d3fd52e6c2e3eab.tar.zst
freebsd-ports-gnome-05705cb0329336f63e44780e1d3fd52e6c2e3eab.zip
* Documentation cosmetics, requested by David Magda <dmagda@magda.ca>.
* Fix include path to enable building if an older version is already installed.
Diffstat (limited to 'audio/flac/Makefile')
-rw-r--r--audio/flac/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index 0a06bf95d8fb..992b7783d07a 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flac
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -37,11 +38,13 @@ PLIST_SUB= XMMS="@comment "
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
+USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS+=--enable-sse --enable-3dnow \
--with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}"
+CONFIGURE_ENV+= CPPFLAGS="-I${WRKSRC}/include"
.if defined(NOPORTDOCS)
MAKE_ENV= DOC=""
@@ -56,6 +59,9 @@ MAN1= flac.1 metaflac.1
post-configure:
@${RM} -rf ${WRKSRC}/obj
+post-build:
+ ${REINPLACE_CMD} 's:%%PREFIX%%:${PREFIX}:' ${WRKSRC}/man/flac.1
+
test: build
@cd ${WRKSRC}; make check