aboutsummaryrefslogtreecommitdiffstats
path: root/audio/flac/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-06-10 23:40:08 +0800
committernaddy <naddy@FreeBSD.org>2003-06-10 23:40:08 +0800
commit73942963108ca71ea3fa975ae0a5c61c490371cc (patch)
tree6ba0f39393905130e729f9db4537e35634490ff5 /audio/flac/Makefile
parente6bed56372f7ea1814bde65333a96aeb04a8e395 (diff)
downloadfreebsd-ports-gnome-73942963108ca71ea3fa975ae0a5c61c490371cc.tar.gz
freebsd-ports-gnome-73942963108ca71ea3fa975ae0a5c61c490371cc.tar.zst
freebsd-ports-gnome-73942963108ca71ea3fa975ae0a5c61c490371cc.zip
Remove option to build the XMMS plugin, which will instead be spun
off into its proper port audio/xmms-flac.
Diffstat (limited to 'audio/flac/Makefile')
-rw-r--r--audio/flac/Makefile25
1 files changed, 5 insertions, 20 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index 992b7783d07a..2b965ddf2ee0 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -7,44 +7,29 @@
PORTNAME= flac
PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-PATCH_SITES= ${MASTER_SITE_DEBIAN}
-PATCH_SITE_SUBDIR= pool/main/f/${PORTNAME}
-PATCHFILES= ${PORTNAME}_${PORTVERSION}-3.diff.gz
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= naddy@FreeBSD.org
COMMENT= Free lossless audio codec
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
ogg.4:${PORTSDIR}/audio/libogg
-.if defined(WITH_XMMS)
-# We don't build with id3lib support, because of C++ related build
-# problems. Detection is disabled by patch-configure.
-BUILD_DEPENDS+= xmms-config:${PORTSDIR}/multimedia/xmms
-LIB_DEPENDS+= xmms.3:${PORTSDIR}/multimedia/xmms
-PLIST_SUB= XMMS=""
-.else
-CONFIGURE_ENV+= XMMS_CONFIG=/usr/bin/false # must be absolute path
-PLIST_SUB= XMMS="@comment "
-.endif
-
.if ${MACHINE_ARCH} == "i386"
-BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.endif
USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-CONFIGURE_ARGS+=--enable-sse --enable-3dnow \
+CONFIGURE_ARGS= --enable-sse --enable-3dnow \
--with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}"
-CONFIGURE_ENV+= CPPFLAGS="-I${WRKSRC}/include"
+CONFIGURE_ENV= CPPFLAGS="-I${WRKSRC}/include" \
+ XMMS_CONFIG=/usr/bin/false # must be absolute path
.if defined(NOPORTDOCS)
MAKE_ENV= DOC=""