aboutsummaryrefslogtreecommitdiffstats
path: root/audio/flac
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2008-07-06 00:24:10 +0800
committernaddy <naddy@FreeBSD.org>2008-07-06 00:24:10 +0800
commitf8c2ee34f5d73b4db860746c66356adf719147ba (patch)
treeb1c15f645dc46a765dc0aa6b7e30a32ca19d91ec /audio/flac
parent95ddde0a1d6b9d473032055a3b8551eb498023ce (diff)
downloadfreebsd-ports-gnome-f8c2ee34f5d73b4db860746c66356adf719147ba.tar.gz
freebsd-ports-gnome-f8c2ee34f5d73b4db860746c66356adf719147ba.tar.zst
freebsd-ports-gnome-f8c2ee34f5d73b4db860746c66356adf719147ba.zip
Add WITHOUT_ICONV knob. Use at your own peril.
PR: 124181 Submitted by: Helge Oldach
Diffstat (limited to 'audio/flac')
-rw-r--r--audio/flac/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index aadc6a42741a..37c7d32f9346 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -17,16 +17,21 @@ COMMENT= Free lossless audio codec
LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
USE_AUTOTOOLS= libtool:15
-USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --enable-sse \
- --with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}" \
--disable-thorough-tests \
--disable-xmms-plugin
CONFIGURE_ENV= CPPFLAGS="-I${WRKSRC}/include"
+.if !defined(WITHOUT_ICONV)
+USE_ICONV= yes
+CONFIGURE_ARGS+=--with-libiconv-prefix="${LOCALBASE}"
+.else
+CONFIGURE_ARGS+=--without-libiconv-prefix
+.endif
+
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
MAKE_ENV= MAKEOBJDIR=/nonexistent # ignore ${WRKSRC}/obj
.if defined(NOPORTDOCS)