aboutsummaryrefslogtreecommitdiffstats
path: root/audio/fluidsynth
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-04 19:51:39 +0800
committerpav <pav@FreeBSD.org>2003-12-04 19:51:39 +0800
commit678b04429d4a4c49d58df778c1da8302b6e43377 (patch)
tree7d8149e1002a944afa1cff4473c52fddbc583405 /audio/fluidsynth
parent3c800610617805281239a5cc2a796a5ef75b2afb (diff)
downloadfreebsd-ports-gnome-678b04429d4a4c49d58df778c1da8302b6e43377.tar.gz
freebsd-ports-gnome-678b04429d4a4c49d58df778c1da8302b6e43377.tar.zst
freebsd-ports-gnome-678b04429d4a4c49d58df778c1da8302b6e43377.zip
Add fluidsynth, a real-time software synthesizer based on the SoundFont 2
specifications. It is a "software synthesizer". FluidSynth can read MIDI events from the MIDI input device and render them to the audio device. It can also play MIDI files. PR: ports/59716 Submitted by: Juha Nygard <juha.nygard1@netikka.fi> Approved by: adamw (mentor)
Diffstat (limited to 'audio/fluidsynth')
-rw-r--r--audio/fluidsynth/Makefile31
-rw-r--r--audio/fluidsynth/distinfo1
-rw-r--r--audio/fluidsynth/files/patch-configure10
-rw-r--r--audio/fluidsynth/pkg-descr8
-rw-r--r--audio/fluidsynth/pkg-plist24
5 files changed, 74 insertions, 0 deletions
diff --git a/audio/fluidsynth/Makefile b/audio/fluidsynth/Makefile
new file mode 100644
index 000000000000..bf415bafe3c0
--- /dev/null
+++ b/audio/fluidsynth/Makefile
@@ -0,0 +1,31 @@
+# ports collection makefile for: fluidsynth
+# Date created: 27 Nov 2003
+# Whom: Juha Nygard <juha.nygard1@netikka.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fluidsynth
+PORTVERSION= 1.0.3
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= fluid//stable.pkg/${PORTVERSION}
+
+MAINTAINER= juha.nygard1@netikka.fi
+COMMENT= Real-time software synthesizer based on the SoundFont 2 specifications
+
+INSTALLS_SHLIB= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_GETOPT_LONG= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LIBS="${PTHREAD_LIBS}"
+
+MAN1= fluidsynth.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/fluidsynth/distinfo b/audio/fluidsynth/distinfo
new file mode 100644
index 000000000000..9533f9b31282
--- /dev/null
+++ b/audio/fluidsynth/distinfo
@@ -0,0 +1 @@
+MD5 (fluidsynth-1.0.3.tar.gz) = fbdccd05e538626888e27b58d3bdbc2b
diff --git a/audio/fluidsynth/files/patch-configure b/audio/fluidsynth/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/audio/fluidsynth/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/fluidsynth/pkg-descr b/audio/fluidsynth/pkg-descr
new file mode 100644
index 000000000000..23705070fb92
--- /dev/null
+++ b/audio/fluidsynth/pkg-descr
@@ -0,0 +1,8 @@
+FluidSynth is a real-time software synthesizer based on the SoundFont 2
+specifications. It is a "software synthesizer". FluidSynth can read MIDI
+events from the MIDI input device and render them to the audio device.
+It can also play MIDI files.
+
+Note: FluidSynth was previously called IIWU Synth.
+
+WWW: http://www.fluidsynth.org/
diff --git a/audio/fluidsynth/pkg-plist b/audio/fluidsynth/pkg-plist
new file mode 100644
index 000000000000..3269256698bf
--- /dev/null
+++ b/audio/fluidsynth/pkg-plist
@@ -0,0 +1,24 @@
+bin/fluidsynth
+lib/libfluidsynth.so.1
+lib/libfluidsynth.so
+lib/libfluidsynth.a
+include/fluidsynth/audio.h
+include/fluidsynth/event.h
+include/fluidsynth/gen.h
+include/fluidsynth/log.h
+include/fluidsynth/midi.h
+include/fluidsynth/misc.h
+include/fluidsynth/mod.h
+include/fluidsynth/ramsfont.h
+include/fluidsynth/seq.h
+include/fluidsynth/seqbind.h
+include/fluidsynth/settings.h
+include/fluidsynth/sfont.h
+include/fluidsynth/shell.h
+include/fluidsynth/synth.h
+include/fluidsynth/types.h
+include/fluidsynth/version.h
+include/fluidsynth/voice.h
+include/fluidsynth.h
+libdata/pkgconfig/fluidsynth.pc
+@dirrm include/fluidsynth