aboutsummaryrefslogtreecommitdiffstats
path: root/audio/fmio/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-04-29 22:57:53 +0800
committersobomax <sobomax@FreeBSD.org>2002-04-29 22:57:53 +0800
commit1dad6f4c5708b87cdf0f13deac9b2a513c5c991e (patch)
treebe5bc9c9f8286c6c0f3a3d5c8801b17f0f4c72bd /audio/fmio/Makefile
parentcb5581d80c4c46e74cf3523a1cab7b6e1f27a8cd (diff)
downloadfreebsd-ports-gnome-1dad6f4c5708b87cdf0f13deac9b2a513c5c991e.tar.gz
freebsd-ports-gnome-1dad6f4c5708b87cdf0f13deac9b2a513c5c991e.tar.zst
freebsd-ports-gnome-1dad6f4c5708b87cdf0f13deac9b2a513c5c991e.zip
- Use proper ${INSTALL_XXX} instead of ${INSTALL} for installing binaries and
scripts; - remove junk at the beginning of files/bktrctl.sh. PR: 37427 Submitted by: maintainer
Diffstat (limited to 'audio/fmio/Makefile')
-rw-r--r--audio/fmio/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/audio/fmio/Makefile b/audio/fmio/Makefile
index d21142372b6e..5c1ba5a3010e 100644
--- a/audio/fmio/Makefile
+++ b/audio/fmio/Makefile
@@ -16,28 +16,29 @@ MAN1= fmio.1
MANCOMPRESSED= no
pre-build:
-.if !defined(WITH_XTREME)
+.if !defined(WITH_BKTR)
@${ECHO_MSG}
@${ECHO_MSG} "If you want to compile with Highway Xtreme support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_XTREME=yes\""
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BKTR=yes\""
@${ECHO_MSG}
.endif
post-build:
-.if defined(WITH_XTREME)
+.if defined(WITH_BKTR)
@${MAKE} ${WRKSRC}/utils/bktrctl
.endif
do-install:
-.if defined(WITH_XTREME)
- ${INSTALL} ${WRKSRC}/utils/bktrctl ${PREFIX}/bin
- ${INSTALL} ${FILESDIR}/bktrctl.sh ${PREFIX}/etc/rc.d
+.if defined(WITH_BKTR)
+ ${INSTALL_PROGRAM} ${WRKSRC}/utils/bktrctl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${FILESDIR}/bktrctl.sh ${PREFIX}/etc/rc.d
.endif
- ${INSTALL} -m 4555 ${WRKSRC}/fmio ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/fmio ${PREFIX}/bin
+ ${CHMOD} 4555 ${PREFIX}/bin/fmio
${INSTALL_MAN} ${WRKSRC}/fmio.1 ${MANPREFIX}/man/man1
post-install:
-.if !defined(WITH_XTREME)
+.if !defined(WITH_BKTR)
${GREP} -v "bktrctl.sh" ${TMPPLIST} > ${TMPPLIST}.tmp
${MV} -f ${TMPPLIST}.tmp ${TMPPLIST}
.endif