aboutsummaryrefslogtreecommitdiffstats
path: root/audio/freealut
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-08-07 23:07:19 +0800
committeroliver <oliver@FreeBSD.org>2006-08-07 23:07:19 +0800
commit652476df40b5d0aaf2bb05b56a448a513c951fa5 (patch)
tree3e35ee46496a7d0b40eb4add8eb4023a23685250 /audio/freealut
parentf9a96bebe02262475014f8a9c3a48111c0f80e44 (diff)
downloadfreebsd-ports-gnome-652476df40b5d0aaf2bb05b56a448a513c951fa5.tar.gz
freebsd-ports-gnome-652476df40b5d0aaf2bb05b56a448a513c951fa5.tar.zst
freebsd-ports-gnome-652476df40b5d0aaf2bb05b56a448a513c951fa5.zip
- fix a compatibility function (unbreaks games/flightgear,
games/trigger and probably several others as well) - do not overwrite CFLAGS (in case the user wants to pass a custom CFLAGS as a make argument) - bump PORTREVISION Submitted by: jylefort
Diffstat (limited to 'audio/freealut')
-rw-r--r--audio/freealut/Makefile3
-rw-r--r--audio/freealut/files/patch-src_alutLoader.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/audio/freealut/Makefile b/audio/freealut/Makefile
index 2e7b7e9f115e..c7997d218398 100644
--- a/audio/freealut/Makefile
+++ b/audio/freealut/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freealut
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.openal.org/openal_webstf/downloads/ \
http://aedion.de/openal/
@@ -17,7 +18,7 @@ COMMENT= The OpenAL Utility Toolkit
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
USE_GNOME= pkgconfig gnomehack
INSTALLS_SHLIB= yes
diff --git a/audio/freealut/files/patch-src_alutLoader.c b/audio/freealut/files/patch-src_alutLoader.c
new file mode 100644
index 000000000000..d395cd9602dd
--- /dev/null
+++ b/audio/freealut/files/patch-src_alutLoader.c
@@ -0,0 +1,11 @@
+--- src/alutLoader.c.orig Sun Aug 6 19:00:08 2006
++++ src/alutLoader.c Sun Aug 6 19:01:10 2006
+@@ -474,7 +474,7 @@
+
+ /* ToDo: Can we do something less insane than passing 0x7FFFFFFF? */
+ stream = _alutInputStreamConstructFromMemory (buffer, 0x7FFFFFFF);
+- _alutLoadMemoryFromInputStream (stream, format, size, &freq);
++ *data = _alutLoadMemoryFromInputStream (stream, format, size, &freq);
+ if (*data == NULL)
+ {
+ return;