aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gdam/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-07 06:48:48 +0800
committermarcus <marcus@FreeBSD.org>2003-11-07 06:48:48 +0800
commita3a02a3a5a02dae7252c154dbdeff2c04209f09a (patch)
treec83a584a9d21c93532d967b1e060f912b451ef02 /audio/gdam/Makefile
parented8f0f48b9437038cacb05d8184df64779c24c27 (diff)
downloadfreebsd-ports-gnome-a3a02a3a5a02dae7252c154dbdeff2c04209f09a.tar.gz
freebsd-ports-gnome-a3a02a3a5a02dae7252c154dbdeff2c04209f09a.tar.zst
freebsd-ports-gnome-a3a02a3a5a02dae7252c154dbdeff2c04209f09a.zip
Add gdam, a DJ mixing application suitable for live performances. GDam offers:
* Client/server architecture * Mixing of multiple mp3 files * Dynamic filter insertion and removal * Multiple sound device support (speakers and monitor) * Loops, queues, sampler, beat matching, sequencer * Record your performance to a disk And it's blue! PR: 59025 Submitted by: Pav Lucistnik <pav@oook.cz> Requested by: Martin Vana <martin.vana@vslib.cz>
Diffstat (limited to 'audio/gdam/Makefile')
-rw-r--r--audio/gdam/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/audio/gdam/Makefile b/audio/gdam/Makefile
new file mode 100644
index 000000000000..81c93543e75e
--- /dev/null
+++ b/audio/gdam/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gdam
+# Date created: 6th Nov 2003
+# Whom: Pav Lucistnik <pav@oook.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdam
+PORTVERSION= 0.942
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pav@oook.cz
+COMMENT= DJ mixing software suitable for live performances
+
+BUILD_DEPENDS= ${X11BASE}/include/xmms/plugin.h:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
+
+MAN1= gdamcli.1 gdamladspapluginscanner.1 gdam123.1 gdam-launcher.1 gdam-server.1
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= libglade
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lglib -lgtk|-lglib12 -lgtk12|' ${WRKSRC}/skin/foreign/xmmsvis/Makefile.in
+
+.include <bsd.port.mk>