aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gnaural
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2012-01-25 21:14:47 +0800
committermartymac <martymac@FreeBSD.org>2012-01-25 21:14:47 +0800
commit3ea892d7c5147aad6515827383e44b3880ba1384 (patch)
tree4ef7ee603151433db787bb8f70ecfbd9e9e707cb /audio/gnaural
parentc8b948ddaeb0439056377cef4ffd8d5b949e0c97 (diff)
downloadfreebsd-ports-gnome-3ea892d7c5147aad6515827383e44b3880ba1384.tar.gz
freebsd-ports-gnome-3ea892d7c5147aad6515827383e44b3880ba1384.tar.zst
freebsd-ports-gnome-3ea892d7c5147aad6515827383e44b3880ba1384.zip
Add Gnaural, a binaural beat generator
Diffstat (limited to 'audio/gnaural')
-rw-r--r--audio/gnaural/Makefile27
-rw-r--r--audio/gnaural/distinfo2
-rw-r--r--audio/gnaural/files/patch-Makefile.in23
-rw-r--r--audio/gnaural/pkg-descr3
-rw-r--r--audio/gnaural/pkg-plist9
5 files changed, 64 insertions, 0 deletions
diff --git a/audio/gnaural/Makefile b/audio/gnaural/Makefile
new file mode 100644
index 000000000000..04fece10350d
--- /dev/null
+++ b/audio/gnaural/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gnaural
+# Date created: 25 Jan 2012
+# Whom: Ganael Laplanche <ganael.laplanche@martymac.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnaural
+PORTVERSION= 1.0.20110606
+CATEGORIES= audio
+MASTER_SITES= SF/${PORTNAME}/Gnaural/
+
+MAINTAINER= martymac@FreeBSD.org
+COMMENT= Binaural beat generator
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= portaudio.2:${PORTSDIR}/audio/portaudio2 \
+ sndfile.1:${PORTSDIR}/audio/libsndfile
+
+GNU_CONFIGURE= yes
+USE_GNOME= libglade2 desktopfileutils
+
+post-install:
+ -@update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/audio/gnaural/distinfo b/audio/gnaural/distinfo
new file mode 100644
index 000000000000..db66473adb01
--- /dev/null
+++ b/audio/gnaural/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnaural-1.0.20110606.tar.gz) = 8dc5806509735720345c19d47c4f2d7912eb1def4f02d21102361e9fe33f6bb8
+SIZE (gnaural-1.0.20110606.tar.gz) = 413895
diff --git a/audio/gnaural/files/patch-Makefile.in b/audio/gnaural/files/patch-Makefile.in
new file mode 100644
index 000000000000..3f8ae3ef91b4
--- /dev/null
+++ b/audio/gnaural/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+--- Makefile.in.orig 2011-05-26 00:38:21.000000000 +0200
++++ Makefile.in 2012-01-18 07:12:38.767047961 +0100
+@@ -742,15 +742,16 @@
+ install-data-local:
+ @$(NORMAL_INSTALL)
+ if test -d $(srcdir)/pixmaps; then \
+- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps; \
+ for pixmap in $(srcdir)/pixmaps/*; do \
+ if test -f $$pixmap; then \
+- $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
++ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(datadir)/pixmaps; \
+ fi \
+ done \
+ fi; \
+- $(mkinstalldirs) $(DESTDIR)$(datadir)/gnome/apps/Multimedia; \
+- $(INSTALL_DATA) gnaural.desktop $(DESTDIR)$(datadir)/gnome/apps/Multimedia; \
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/applications; \
++ $(INSTALL_DATA) gnaural.desktop $(DESTDIR)$(datadir)/applications; \
++ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir); \
+ $(INSTALL_DATA) src/gnaural.glade $(DESTDIR)$(pkgdatadir);
+
+ dist-hook:
diff --git a/audio/gnaural/pkg-descr b/audio/gnaural/pkg-descr
new file mode 100644
index 000000000000..ef30fabdee3a
--- /dev/null
+++ b/audio/gnaural/pkg-descr
@@ -0,0 +1,3 @@
+Audio synthesizer intended for use as a binaural beat generator.
+
+WWW: http://gnaural.sourceforge.net
diff --git a/audio/gnaural/pkg-plist b/audio/gnaural/pkg-plist
new file mode 100644
index 000000000000..dcbde4c5454b
--- /dev/null
+++ b/audio/gnaural/pkg-plist
@@ -0,0 +1,9 @@
+bin/gnaural
+%%DATADIR%%/gnaural.glade
+share/applications/gnaural.desktop
+share/pixmaps/gnaural-icon.xpm
+share/pixmaps/gnaural-icon.png
+@dirrmtry share/applications
+@dirrm %%DATADIR%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true