aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gnomad2/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-07 05:22:05 +0800
committermiwi <miwi@FreeBSD.org>2006-12-07 05:22:05 +0800
commitf3d326dda684e1dada09b17d92fe0a0889444c30 (patch)
tree616154f2eb60d0b71ba2f5b5ba0703afc3e75972 /audio/gnomad2/Makefile
parent3dec5de50a139730a2ad40c88564fdf984c0318d (diff)
downloadfreebsd-ports-gnome-f3d326dda684e1dada09b17d92fe0a0889444c30.tar.gz
freebsd-ports-gnome-f3d326dda684e1dada09b17d92fe0a0889444c30.tar.zst
freebsd-ports-gnome-f3d326dda684e1dada09b17d92fe0a0889444c30.zip
Gnomad2 is a GTK+ music manager and swiss army knife for the Creative Labs
NOMAD and Zen range plus the Dell DJ devices using the Portable Digital Entertainment (PDE) protocol. WWW: http://gnomad2.sourceforge.net PR: ports/106424 Submitted by: Petar Zhivkov Petrov (pesho.petrov at gmail.com)
Diffstat (limited to 'audio/gnomad2/Makefile')
-rw-r--r--audio/gnomad2/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/gnomad2/Makefile b/audio/gnomad2/Makefile
new file mode 100644
index 000000000000..903247860bab
--- /dev/null
+++ b/audio/gnomad2/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gnomad2
+# Date created: 3 December 2006
+# Whom: Petar Zhivkov Petrov (pesho.petrov@gmail.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomad2
+PORTVERSION= 2.8.9
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pesho.petrov@gmail.com
+COMMENT= A program for the NOMAD Jukebox to handle jukebox communication
+
+LIB_DEPENDS= mtp:${PORTSDIR}/audio/libmtp \
+ njb.6:${PORTSDIR}/audio/libnjb \
+ id3tag.0:${PORTSDIR}/audio/libid3tag
+
+MAN1= gnomad2.1
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+USE_GMAKE= yes
+USE_GNOME= libglade2 libgnomeui
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>