aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gnormalize
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-02-08 01:15:31 +0800
committerrafan <rafan@FreeBSD.org>2008-02-08 01:15:31 +0800
commite703639939c136ac37e0802a370acf60a496d38d (patch)
tree3031bc33fc6da425d0c151ce1713f833d1563084 /audio/gnormalize
parent3d75237f8e0e974fc19606517a882f88d2e3260c (diff)
downloadfreebsd-ports-gnome-e703639939c136ac37e0802a370acf60a496d38d.tar.gz
freebsd-ports-gnome-e703639939c136ac37e0802a370acf60a496d38d.tar.zst
freebsd-ports-gnome-e703639939c136ac37e0802a370acf60a496d38d.zip
gnormalize decodes the MP3/MP4/MPC/OGG/APE/FLAC file to WAV,
then normalizes the WAV to a targeted volume level and re-encodes it. Moreover, gnormalize can extract Audio CD track and output as various popular audio formats (MP3, MP4, MPC, OGG, APE, FLAC, WAV) with fast speed and high quality. gnormalize can also convert audio format between MP3, MP4, MPC, OGG, APE and FLAC with high fidelity, which meets your need to play and collect audio files. It can change the encoding and Metadata (tag) properties of final normalized files. WWW: http://gnormalize.sourceforge.net/ PR: ports/117544 Submitted by: Denise H. G. <darcsis at gmail.com>
Diffstat (limited to 'audio/gnormalize')
-rw-r--r--audio/gnormalize/Makefile55
-rw-r--r--audio/gnormalize/distinfo3
-rw-r--r--audio/gnormalize/files/patch-Makefile68
-rw-r--r--audio/gnormalize/pkg-descr10
-rw-r--r--audio/gnormalize/pkg-plist18
5 files changed, 154 insertions, 0 deletions
diff --git a/audio/gnormalize/Makefile b/audio/gnormalize/Makefile
new file mode 100644
index 000000000000..2772c6c4187f
--- /dev/null
+++ b/audio/gnormalize/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: gnormalize
+# Date created: 27 Oct 2007
+# Whom: Denise H. G. <darcsis@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnormalize
+PORTVERSION= 0.52
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= darcsis@gmail.com
+COMMENT= An alternative for replaygain
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ ${SITE_PERL}/${PERL_ARCH}/Audio/CD.pm:${PORTSDIR}/audio/p5-Audio-CD \
+ ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
+ ${SITE_PERL}/${PERL_ARCH}/auto/Encode/Encode.so:${PORTSDIR}/converters/p5-Encode \
+ normalize:${PORTSDIR}/audio/normalize \
+ cddb.pl:${PORTSDIR}/audio/p5-CDDB_get \
+ lame:${PORTSDIR}/audio/lame \
+ faac:${PORTSDIR}/audio/faac \
+ oggenc:${PORTSDIR}/audio/vorbis-tools \
+ mppenc:${PORTSDIR}/audio/musepack \
+ mac:${PORTSDIR}/audio/mac \
+ flac:${PORTSDIR}/audio/flac \
+ faad:${PORTSDIR}/audio/faad
+
+USE_PERL5_RUN= yes
+INSTALLS_ICONS= yes
+
+NO_BUILD= yes
+
+MAN1= gnormalize.1
+
+pre-extract:
+ @${ECHO} ""
+ @${ECHO} "[N-O-T-I-C-E]"
+ @${ECHO} " A threaded perl is needed to run ${PORTNAME}-${PORTVERSION}."
+ @${ECHO} " If your perl is not compiled with thread support. Consider"
+ @${ECHO} " recompiling your perl with thread support. For more information,"
+ @${ECHO} " please read ${PORTSDIR}/lang/perl5.8/Makefile."
+ @${ECHO} ""
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^PREFIX=.*,PREFIX=${PREFIX},; \
+ s,^MANDIR=.*,MANDIR=${MANPREFIX}/man,; \
+ s,^BASE=.*,BASE=${DATADIR},' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,/usr/share/gnormalize,${DATADIR},' \
+ ${WRKSRC}/gnormalize
+
+.include <bsd.port.mk>
diff --git a/audio/gnormalize/distinfo b/audio/gnormalize/distinfo
new file mode 100644
index 000000000000..a2f2fa1a7912
--- /dev/null
+++ b/audio/gnormalize/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnormalize-0.52.tar.gz) = f577b8dc57bceca9a8a02b7f00dccbe3
+SHA256 (gnormalize-0.52.tar.gz) = 61132285436f94637a5ed5db2ba1909fb75c629aaa580b5a9069f8b0b8428d4b
+SIZE (gnormalize-0.52.tar.gz) = 690984
diff --git a/audio/gnormalize/files/patch-Makefile b/audio/gnormalize/files/patch-Makefile
new file mode 100644
index 000000000000..450637f46af8
--- /dev/null
+++ b/audio/gnormalize/files/patch-Makefile
@@ -0,0 +1,68 @@
+--- Makefile.orig 2006-12-03 04:31:26.000000000 +0800
++++ Makefile 2008-02-07 13:09:06.000000000 +0800
+@@ -1,6 +1,5 @@
+ PREFIX=/usr
+ BINDIR=$(PREFIX)/bin
+-DOCDIR=$(PREFIX)/share/doc/gnormalize
+ ICONDIR=$(PREFIX)/share/icons
+ ICONDIR2=$(PREFIX)/share/pixmaps
+ LICONDIR=$(ICONDIR)/large
+@@ -8,8 +7,11 @@
+ BASE=$(PREFIX)/share/gnormalize
+ ANIMDIR=$(BASE)/animations
+ MANDIR=$(PREFIX)/share/man
++INSTALL_PROG=install -m 755 -o root -g wheel
++INSTALL_DATA=install -m 444 -o root -g wheel
+
+ DOCS=README
++MAN_PAGE=gnormalize.1
+
+ all:
+ clean:
+@@ -17,21 +19,22 @@
+
+
+ install: all
++ cat ${MAN_PAGE}.bz2 | bzip2 -d -- > ${MAN_PAGE}
+ mkdir -p "$(BINDIR)"
+ mkdir -p "$(ICONDIR)"
+ mkdir -p "$(ICONDIR2)"
++ mkdir -p "$(LICONDIR)"
++ mkdir -p "$(MICONDIR)"
+ mkdir -p "$(ANIMDIR)"
+- mkdir -p "$(DOCDIR)"
+ mkdir -p "$(MANDIR)/man1/"
+- install -Dm 755 gnormalize "$(BINDIR)/gnormalize"
+- install -m 644 $(DOCS) "$(DOCDIR)/"
+- install -m 644 $(DOCS) "$(BASE)/"
+- install -m 644 gnormalize.1.bz2 "$(MANDIR)/man1/gnormalize.1.bz2"
++ $(INSTALL_PROG) gnormalize "$(BINDIR)/gnormalize"
++ $(INSTALL_DATA) $(DOCS) "$(BASE)/"
++ $(INSTALL_DATA) ${MAN_PAGE} "$(MANDIR)/man1/${MAN_PAGE}"
+ install -d "$(ANIMDIR)"
+- install -m 644 animations/*.gif "$(ANIMDIR)/"
+- install -Dm 644 icons/gnormalize-32.png "$(ICONDIR)/gnormalize.png"
+- install -Dm 644 icons/gnormalize-48.png "$(LICONDIR)/gnormalize.png"
+- install -Dm 644 icons/gnormalize-16.png "$(MICONDIR)/gnormalize.png"
++ $(INSTALL_DATA) animations/*.gif "$(ANIMDIR)/"
++ $(INSTALL_DATA) icons/gnormalize-32.png "$(ICONDIR)/gnormalize.png"
++ $(INSTALL_DATA) icons/gnormalize-48.png "$(LICONDIR)/gnormalize.png"
++ $(INSTALL_DATA) icons/gnormalize-16.png "$(MICONDIR)/gnormalize.png"
+ ln -sf "$(ICONDIR)/gnormalize.png" "$(ICONDIR2)/gnormalize.png"
+
+ postinstall:
+@@ -39,13 +42,12 @@
+
+ uninstall:
+ rm -f "$(BINDIR)/gnormalize"
+- rm -f "$(MANDIR)/man1/gnormalize.1.bz2"
++ rm -f "$(MANDIR)/man1/gnormalize.1"
+ rm -f "$(ICONDIR)/gnormalize.png"
+ rm -f "$(LICONDIR)/gnormalize.png"
+ rm -f "$(MICONDIR)/gnormalize.png"
+ unlink "$(ICONDIR2)/gnormalize.png"
+ rm -rf "$(BASE)"
+- rm -rf "$(PREFIX)/share/doc/gnormalize"
+
+ postuninstall:
+ update-menus
diff --git a/audio/gnormalize/pkg-descr b/audio/gnormalize/pkg-descr
new file mode 100644
index 000000000000..0e35de20cc80
--- /dev/null
+++ b/audio/gnormalize/pkg-descr
@@ -0,0 +1,10 @@
+gnormalize decodes the MP3/MP4/MPC/OGG/APE/FLAC file to WAV,
+then normalizes the WAV to a targeted volume level and re-encodes
+it. Moreover, gnormalize can extract Audio CD track and output as
+various popular audio formats (MP3, MP4, MPC, OGG, APE, FLAC, WAV)
+with fast speed and high quality. gnormalize can also convert audio
+format between MP3, MP4, MPC, OGG, APE and FLAC with high fidelity,
+which meets your need to play and collect audio files. It can change
+the encoding and Metadata (tag) properties of final normalized files.
+
+WWW: http://gnormalize.sourceforge.net/
diff --git a/audio/gnormalize/pkg-plist b/audio/gnormalize/pkg-plist
new file mode 100644
index 000000000000..2f589aea3096
--- /dev/null
+++ b/audio/gnormalize/pkg-plist
@@ -0,0 +1,18 @@
+bin/gnormalize
+%%DATADIR%%/animations/dancing_penguin.gif
+%%DATADIR%%/animations/penguin_cold.gif
+%%DATADIR%%/animations/penguin_ice.gif
+%%DATADIR%%/animations/super_tux.gif
+%%DATADIR%%/animations/penguin_and_camel.gif
+%%DATADIR%%/animations/penguin_computer.gif
+%%DATADIR%%/animations/penguin_typing.gif
+%%DATADIR%%/animations/tux_lunapaint.gif
+%%DATADIR%%/README
+share/icons/gnormalize.png
+share/icons/large/gnormalize.png
+share/icons/mini/gnormalize.png
+share/pixmaps/gnormalize.png
+@dirrmtry %%DATADIR%%/animations
+@dirrmtry %%DATADIR%%
+@dirrmtry share/icons/large
+@dirrmtry share/icons/mini