aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gnuitar/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-04 06:22:11 +0800
committeredwin <edwin@FreeBSD.org>2005-12-04 06:22:11 +0800
commit2b376e4b669e39af12b8f3886cd0e19fdc55f0bf (patch)
treea1d0deac5238380e8495c8fdcac535897d28aeb7 /audio/gnuitar/Makefile
parentc4f42b1b4f7b70fe75f0c1e76230cae4c0e851dc (diff)
downloadfreebsd-ports-gnome-2b376e4b669e39af12b8f3886cd0e19fdc55f0bf.tar.gz
freebsd-ports-gnome-2b376e4b669e39af12b8f3886cd0e19fdc55f0bf.tar.zst
freebsd-ports-gnome-2b376e4b669e39af12b8f3886cd0e19fdc55f0bf.zip
[new port] audio/gnuitar
This is an open source program for real-time sound effect processing. You can use it to add some distortion to your guitar, or some reverb to your voice. Available effects are: * 2 kinds of distortion (one is Ibanez TubeScreamer 9 simulation) * sustain * various flavors of reverb, echo & delay * chorus/flanger * equalizer * noise reduction * wah-wah * phasor * tremolo * vibrato WWW: http://www.gnuitar.com PR: ports/89895 Submitted by: Gabor Kovesdan <gabor.kovesdan@t-hosting.hu>
Diffstat (limited to 'audio/gnuitar/Makefile')
-rw-r--r--audio/gnuitar/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/gnuitar/Makefile b/audio/gnuitar/Makefile
new file mode 100644
index 000000000000..06545beb06da
--- /dev/null
+++ b/audio/gnuitar/Makefile
@@ -0,0 +1,27 @@
+# Ports collection Makefile for: gnuitar
+# Date created: 3 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= gnuitar
+PORTVERSION= 0.3.2
+CATEGORIES= audio multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tar.bz2
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= The real-time guitar processor
+
+USE_X_PREFIX= YES
+USE_GNOME= gtk20 glib20
+WANT_GNOME= YES
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS+=--with-gtk2 \
+ --enable-clip-everywhere \
+ --enable-float
+
+pre-fetch:
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>