aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gnump3d/files
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-08-14 08:03:26 +0800
committernaddy <naddy@FreeBSD.org>2002-08-14 08:03:26 +0800
commit714c4e18805009109b98dcc2b7c97a817790758d (patch)
treec8266e8a0aee2146ea8292e9f8e3665eb30c0a76 /audio/gnump3d/files
parent3a6d0011f6bc5009fd8665fb50c3fffda3d4bb99 (diff)
downloadfreebsd-ports-gnome-714c4e18805009109b98dcc2b7c97a817790758d.tar.gz
freebsd-ports-gnome-714c4e18805009109b98dcc2b7c97a817790758d.tar.zst
freebsd-ports-gnome-714c4e18805009109b98dcc2b7c97a817790758d.zip
* Always depend on external libvorbis when building with Ogg Vorbis support.
* This port does not install any shared libraries. * Don't clobber an existing configuration file or remove a modified one. * Don't install .la files for plugins. * Fix build on -CURRENT. * Fix build on 64-bit platforms.
Diffstat (limited to 'audio/gnump3d/files')
-rw-r--r--audio/gnump3d/files/patch-config::ltmain.sh29
-rw-r--r--audio/gnump3d/files/patch-src::threads.cc52
-rw-r--r--audio/gnump3d/files/patch-src_files.cc14
-rw-r--r--audio/gnump3d/files/patch-src_theme.cc19
-rw-r--r--audio/gnump3d/files/patch-templates_Makefile.in14
5 files changed, 124 insertions, 4 deletions
diff --git a/audio/gnump3d/files/patch-config::ltmain.sh b/audio/gnump3d/files/patch-config::ltmain.sh
index d8d418253953..46d28117efca 100644
--- a/audio/gnump3d/files/patch-config::ltmain.sh
+++ b/audio/gnump3d/files/patch-config::ltmain.sh
@@ -1,5 +1,8 @@
---- config/ltmain.sh.orig Sun Jul 14 08:53:50 2002
-+++ config/ltmain.sh Tue Jul 16 00:38:55 2002
+
+$FreeBSD$
+
+--- config/ltmain.sh.orig Sun Jul 14 01:53:50 2002
++++ config/ltmain.sh Tue Aug 13 18:00:19 2002
@@ -967,6 +967,7 @@
;;
@@ -8,3 +11,25 @@
avoid_version=yes
continue
;;
+@@ -1061,7 +1062,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -4273,10 +4274,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/gnump3d/files/patch-src::threads.cc b/audio/gnump3d/files/patch-src::threads.cc
index e3df3f0b3c49..7d7d0102f4bf 100644
--- a/audio/gnump3d/files/patch-src::threads.cc
+++ b/audio/gnump3d/files/patch-src::threads.cc
@@ -1,5 +1,8 @@
---- src/threads.cc.orig Sun Jul 14 08:53:50 2002
-+++ src/threads.cc Tue Jul 16 00:01:18 2002
+
+$FreeBSD$
+
+--- src/threads.cc.orig Sun Jul 14 01:53:50 2002
++++ src/threads.cc Tue Aug 13 22:15:58 2002
@@ -39,6 +39,7 @@
#include <errno.h>
#include <algorithm>
@@ -8,3 +11,48 @@
#include <netinet/in.h>
#include <sys/socket.h>
#include <netdb.h>
+@@ -248,7 +249,7 @@
+ * worry about things like '%2E'.
+ *
+ */
+- if ( path.find( "/../" ) != (unsigned int)-1 )
++ if ( path.find( "/../" ) != std::string::npos )
+ {
+ path = "/";
+ }
+@@ -278,7 +279,7 @@
+ /*
+ * Return a playlist of all the files in the given directory.
+ */
+- if ( path.find( "/all.m3u" ) != (unsigned int)-1 )
++ if ( path.find( "/all.m3u" ) != std::string::npos )
+ {
+ std::string dir;
+ int offset = path.find( "/all.m3u" );
+@@ -307,7 +308,7 @@
+ /*
+ * Return a playlist of all the files in the given directory - Recursively.
+ */
+- if ( path.find( "/recurse.m3u" ) != (unsigned int)-1 )
++ if ( path.find( "/recurse.m3u" ) != std::string::npos )
+ {
+ std::string dir;
+ int offset = path.find( "/recurse.m3u" );
+@@ -337,7 +338,7 @@
+ * Handle streaming a file or a playlist to the client - don't serve
+ * the .password file to clients though..
+ */
+- if ( path.find( "/.password" ) != (unsigned int)-1 )
++ if ( path.find( "/.password" ) != std::string::npos )
+ {
+ std::string errText = "'$PATH' - Not found.";
+
+@@ -441,7 +442,7 @@
+ * as a result of 'always_stream' being set to 1).
+ */
+ if ( settings->alwaysStream() &&
+- ( path.find( ".m3u" ) != (unsigned int)-1 ) )
++ ( path.find( ".m3u" ) != std::string::npos ) )
+ {
+ /* Strip off the '.m3u' suffix */
+ if ( path.size() > 4 )
diff --git a/audio/gnump3d/files/patch-src_files.cc b/audio/gnump3d/files/patch-src_files.cc
new file mode 100644
index 000000000000..cd57d56c0fcb
--- /dev/null
+++ b/audio/gnump3d/files/patch-src_files.cc
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/files.cc.orig Tue Aug 13 22:16:33 2002
++++ src/files.cc Tue Aug 13 22:16:54 2002
+@@ -360,7 +360,7 @@
+ {
+ CFunctionDebug( "CFile::normalize" );
+
+- if ( path.find( "//" ) == (unsigned int) -1)
++ if ( path.find( "//" ) == std::string::npos)
+ {
+ return( path );
+ }
diff --git a/audio/gnump3d/files/patch-src_theme.cc b/audio/gnump3d/files/patch-src_theme.cc
new file mode 100644
index 000000000000..f469eae0b7e6
--- /dev/null
+++ b/audio/gnump3d/files/patch-src_theme.cc
@@ -0,0 +1,19 @@
+
+$FreeBSD$
+
+--- src/theme.cc.orig Tue Aug 13 21:56:19 2002
++++ src/theme.cc Tue Aug 13 21:56:46 2002
+@@ -123,11 +123,11 @@
+ /*
+ * Make sure there's no directory traversal in the theme name.
+ */
+- if ( m_theme.find( ".." ) != (unsigned int)-1 )
++ if ( m_theme.find( ".." ) != std::string::npos )
+ {
+ return 0;
+ }
+- if ( m_theme.find( "/" ) != (unsigned int)-1 )
++ if ( m_theme.find( "/" ) != std::string::npos )
+ {
+ return 0;
+ }
diff --git a/audio/gnump3d/files/patch-templates_Makefile.in b/audio/gnump3d/files/patch-templates_Makefile.in
new file mode 100644
index 000000000000..2feef0461f9f
--- /dev/null
+++ b/audio/gnump3d/files/patch-templates_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- templates/Makefile.in.orig Sun Jul 14 01:53:52 2002
++++ templates/Makefile.in Tue Aug 13 19:19:39 2002
+@@ -192,7 +192,7 @@
+ install:
+ mkdir -p $(sysconfdir)/gnump3d
+ cp gnump3d.conf $(sysconfdir)/gnump3d/gnump3d.conf-default
+- if ! test -e $(sysconfdir)/gnump3d/gnump3d.conf; then mv $(sysconfdir)/gnump3d/gnump3d.conf-default $(sysconfdir)/gnump3d/gnump3d.conf; fi
++ if ! test -e $(sysconfdir)/gnump3d/gnump3d.conf; then cp $(sysconfdir)/gnump3d/gnump3d.conf-default $(sysconfdir)/gnump3d/gnump3d.conf; fi
+ cp -R default $(sysconfdir)/gnump3d
+ cp -R simple $(sysconfdir)/gnump3d
+ cp -R split $(sysconfdir)/gnump3d