aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gogglesmm
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-12-09 00:57:48 +0800
committerbapt <bapt@FreeBSD.org>2011-12-09 00:57:48 +0800
commit9c84ba8f23e1549a45d21fccced1c56b7c044336 (patch)
tree701e1bcc019c7f6405f35e716b1eaad7f7661bbf /audio/gogglesmm
parentce94bbe8ee3a3add102bb54e282386d18f6c00e9 (diff)
downloadfreebsd-ports-gnome-9c84ba8f23e1549a45d21fccced1c56b7c044336.tar.gz
freebsd-ports-gnome-9c84ba8f23e1549a45d21fccced1c56b7c044336.tar.zst
freebsd-ports-gnome-9c84ba8f23e1549a45d21fccced1c56b7c044336.zip
- update to 0.12.5
Feature safe: yes
Diffstat (limited to 'audio/gogglesmm')
-rw-r--r--audio/gogglesmm/Makefile7
-rw-r--r--audio/gogglesmm/distinfo4
-rw-r--r--audio/gogglesmm/files/patch-src__GMAudioScrobbler.cpp13
3 files changed, 5 insertions, 19 deletions
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index b1fddb257369..0a64d0c32c64 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= gogglesmm
-PORTVERSION= 0.12.4
+PORTVERSION= 0.12.5
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
MAINTAINER= bapt@FreeBSD.org
COMMENT= Music collection manager and player
+LICENSE= GPLv3
+
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= xine.1:${PORTSDIR}/multimedia/libxine \
tag.1:${PORTSDIR}/audio/taglib \
@@ -34,9 +36,6 @@ USE_XZ= yes
INSTALLS_ICONS= yes
MAN1= gogglesmm.1
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
-
PORTDOCS= README AUTHORS
.include <bsd.port.options.mk>
diff --git a/audio/gogglesmm/distinfo b/audio/gogglesmm/distinfo
index 063c99660750..8e2a394f0977 100644
--- a/audio/gogglesmm/distinfo
+++ b/audio/gogglesmm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gogglesmm-0.12.4.tar.xz) = d1390e4393ff055fdbccad0b5a5858456c999397b155f214295b4aa839814e84
-SIZE (gogglesmm-0.12.4.tar.xz) = 347776
+SHA256 (gogglesmm-0.12.5.tar.xz) = 653e0b3821d07995f84b0a1d4d3282758523566f780e429592a3b1521f9b45c7
+SIZE (gogglesmm-0.12.5.tar.xz) = 357160
diff --git a/audio/gogglesmm/files/patch-src__GMAudioScrobbler.cpp b/audio/gogglesmm/files/patch-src__GMAudioScrobbler.cpp
deleted file mode 100644
index 7efe5a059e60..000000000000
--- a/audio/gogglesmm/files/patch-src__GMAudioScrobbler.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/GMAudioScrobbler.cpp.orig 2011-03-02 17:15:43.000000000 +0100
-+++ ./src/GMAudioScrobbler.cpp 2011-03-13 19:12:36.773792904 +0100
-@@ -128,10 +128,6 @@
-
- FXint result = connect(server,entry->ai_addr,entry->ai_addrlen);
- if (result!=-1) {
--#if defined(SO_NOSIGPIPE)
-- int onoff=1;
-- setsockopt(server,SOL_SOCKET,SO_NOSIGPIPE,1,(void*)&onoff,sizeof(onoff));
--#endif
- return server;
- }
- ::close(server);