aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gqmpeg
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2000-05-28 08:38:20 +0800
committervanilla <vanilla@FreeBSD.org>2000-05-28 08:38:20 +0800
commit21d2ba04bf131d188084e0b4149787c6474d85aa (patch)
treee066f873068e4952170fb73920a5174ae216b767 /audio/gqmpeg
parente324ab09e4ece0d216895de676484ea744328b4b (diff)
downloadfreebsd-ports-gnome-21d2ba04bf131d188084e0b4149787c6474d85aa.tar.gz
freebsd-ports-gnome-21d2ba04bf131d188084e0b4149787c6474d85aa.tar.zst
freebsd-ports-gnome-21d2ba04bf131d188084e0b4149787c6474d85aa.zip
- Fix LIB_DEPENDS to actually used one
- Support install macros PR: ports/18046 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'audio/gqmpeg')
-rw-r--r--audio/gqmpeg/Makefile5
-rw-r--r--audio/gqmpeg/files/patch-aa26
2 files changed, 20 insertions, 11 deletions
diff --git a/audio/gqmpeg/Makefile b/audio/gqmpeg/Makefile
index 9f3145881527..6a8f4cef9326 100644
--- a/audio/gqmpeg/Makefile
+++ b/audio/gqmpeg/Makefile
@@ -15,12 +15,9 @@ EXTRACT_SUFX= .src.tar.gz
MAINTAINER= nakai@FreeBSD.org
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
-LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib
+LIB_DEPENDS= gdk_imlib.5:${PORTSDIR}/graphics/imlib
USE_X_PREFIX= yes
ALL_TARGET= gqmpeg
-post-install:
- @strip ${PREFIX}/bin/gqmpeg
-
.include <bsd.port.mk>
diff --git a/audio/gqmpeg/files/patch-aa b/audio/gqmpeg/files/patch-aa
index f06e819ff7ca..ede87a7d5504 100644
--- a/audio/gqmpeg/files/patch-aa
+++ b/audio/gqmpeg/files/patch-aa
@@ -1,22 +1,34 @@
---- Makefile.orig Sat Jul 3 04:39:08 1999
-+++ Makefile Mon Jul 5 19:14:39 1999
-@@ -1,8 +1,7 @@
+--- Makefile.orig Sat Jul 3 20:39:08 1999
++++ Makefile Thu Apr 13 03:59:10 2000
+@@ -1,8 +1,8 @@
-PREFIX=/usr/local
++PREFIX?=/usr/local
-GTK_INCLUDE = `gtk-config --cflags`
-GTK_LIB = `gtk-config --libs`
-+GTK_INCLUDE = `gtk12-config --cflags`
-+GTK_LIB = `gtk12-config --libs`
++#GTK_INCLUDE = `gtk-config --cflags`
++#GTK_LIB = `gtk-config --libs`
IMLIB_INCLUDE = `imlib-config --cflags-gdk`
IMLIB_LIB = `imlib-config --libs-gdk`
-@@ -15,7 +14,7 @@
+@@ -15,7 +15,7 @@
#for IRIX
#LDFLAGS = $(GTK_LIB) $(IMLIB_LIB) -laudio
-CC = gcc -Wall
-+CC += -Wall
++CC ?= gcc -Wall
GNOME_PREFIX = `gnome-config --prefix`
+@@ -119,8 +119,8 @@
+ $(CC) $(OBJS) -o gqmpeg.static -static $(LDFLAGS)
+
+ install: gqmpeg
+- install -c gqmpeg $(PREFIX)/bin/gqmpeg
+- install -c plugin/gqmpeg-shoutcast-plugin.sh $(PREFIX)/bin/gqmpeg-shoutcast-plugin.sh
++ ${BSD_INSTALL_PROGRAM} gqmpeg $(PREFIX)/bin/gqmpeg
++ ${BSD_INSTALL_SCRIPT} plugin/gqmpeg-shoutcast-plugin.sh $(PREFIX)/bin/gqmpeg-shoutcast-plugin.sh
+
+ gnome-install: gqmpeg
+ install -c gqmpeg $(PREFIX)/bin/gqmpeg