aboutsummaryrefslogtreecommitdiffstats
path: root/audio/grip/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2009-11-15 20:26:31 +0800
committernaddy <naddy@FreeBSD.org>2009-11-15 20:26:31 +0800
commitcff09ff2f7ba13d1c9ac5a7b27f24b2a5564a800 (patch)
treebf2f244e84b96ed9617d7c251b66a664237a675e /audio/grip/Makefile
parent4026b01942642288d5f56b6bec991236773c27c7 (diff)
downloadfreebsd-ports-gnome-cff09ff2f7ba13d1c9ac5a7b27f24b2a5564a800.tar.gz
freebsd-ports-gnome-cff09ff2f7ba13d1c9ac5a7b27f24b2a5564a800.tar.zst
freebsd-ports-gnome-cff09ff2f7ba13d1c9ac5a7b27f24b2a5564a800.zip
Fix the actual bug that caused translated message catalogs to be
displayed incorrectly, and remove the workaround.
Diffstat (limited to 'audio/grip/Makefile')
-rw-r--r--audio/grip/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 2984a3f02734..86bbcd2e61b3 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= grip
PORTVERSION= 3.2.0
-PORTREVISION= 21
+PORTREVISION= 22
CATEGORIES= audio
MASTER_SITES= SF
@@ -16,7 +16,6 @@ COMMENT= GTK front-end to external cd rippers and audio encoders
LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
curl.5:${PORTSDIR}/ftp/curl
-PATCH_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
USE_XORG= x11
USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui vte
@@ -40,8 +39,6 @@ OPTIONS+= BLADEENC "Encoder: bladeenc: Install audio/bladeenc" off \
FLAC "Encoder: flac: Install audio/flac" off \
GOGO "Encoder: gogo: Install audio/gogo" off
-ISO_LOCALES= de es fr pt_BR
-
.include <bsd.port.pre.mk>
.if defined(WITH_CDROM_DEVICE)
@@ -102,13 +99,5 @@ post-patch:
@${REINPLACE_CMD} -e 's|{"xingmp3enc","-B %b -Q %w","mp3"},||; \
s|{"l3enc","-br %b %w %m","mp3"},|{"faac","--no-midside -w -q 100 --artist %a --album %d --track %t --title %n --year %y --genre %g -b %b %w -o %m", "m4a"},|' \
${WRKSRC}/src/gripcfg.c
-.for l in ${ISO_LOCALES}
- @${MV} ${WRKSRC}/po/${l}.po ${WRKSRC}/po/_${l}.po
- ${LOCALBASE}/bin/iconv -f ISO-8859-15 -t UTF-8 \
- ${WRKSRC}/po/_${l}.po > ${WRKSRC}/po/${l}.po
-.endfor
- @${MV} ${WRKSRC}/po/ru.po ${WRKSRC}/po/_ru.po
- ${LOCALBASE}/bin/iconv -f koi8-r -t UTF-8 \
- ${WRKSRC}/po/_ru.po > ${WRKSRC}/po/ru.po
.include <bsd.port.post.mk>