aboutsummaryrefslogtreecommitdiffstats
path: root/audio/grip
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-06 20:50:58 +0800
committerkrion <krion@FreeBSD.org>2004-01-06 20:50:58 +0800
commita5ea5c146354e2e71570d1ff0c3eca2bc3c38649 (patch)
tree13f1d5a52d2a09e697e69f573c75ec7ee2dc5a02 /audio/grip
parentac2b264b6beea07055e9108de2da6a4f79b0f529 (diff)
downloadfreebsd-ports-gnome-a5ea5c146354e2e71570d1ff0c3eca2bc3c38649.tar.gz
freebsd-ports-gnome-a5ea5c146354e2e71570d1ff0c3eca2bc3c38649.tar.zst
freebsd-ports-gnome-a5ea5c146354e2e71570d1ff0c3eca2bc3c38649.zip
- Fix build WITH_CDPARANOIA=yes
PR: 60972 Submitted by: Esa Karkkainen <ejk@iki.fi>, Ports Fury
Diffstat (limited to 'audio/grip')
-rw-r--r--audio/grip/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 29ac12bb9d98..b0ddadf43c59 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui vte
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -30,4 +31,7 @@ LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
CONFIGURE_ARGS+= --disable-cdpar
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|<cdda/cdda|<cdda|g' ${WRKSRC}/src/cdpar.c
+
.include <bsd.port.mk>