aboutsummaryrefslogtreecommitdiffstats
path: root/audio/grip
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-26 20:35:50 +0800
committerbapt <bapt@FreeBSD.org>2013-04-26 20:35:50 +0800
commit3b719f87a14768433dc0cd06f301eeaf9c02fa43 (patch)
tree94d53c5c905021f480b1c80529f6919181c4c73b /audio/grip
parent6ed47115f3cf9c141188528e8863513cfade4cd8 (diff)
downloadfreebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.tar.gz
freebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.tar.zst
freebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.zip
Remove USE_CDRTOOLS from bsd.port.mk
This macros has been useless since cdrtools-cjk port has gone. This macros also lead to badly handled dependencies assuming that the dependency on cdrtools was most BUILD and RUN dependency. While most of the time it is simply a RUN dependency and sometime a build one. While here: - Trim some headers - Convert some ports to optionsng - Convert some ports to USES= gettext
Diffstat (limited to 'audio/grip')
-rw-r--r--audio/grip/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 7d285081c66e..0e8ef304f11a 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -22,7 +22,7 @@ USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= CDPARANOIA CDDA2WAV LAME VORBIS FAAC FLAC
+OPTIONS_DEFINE= CDPARANOIA CDDA2WAV LAME VORBIS FAAC FLAC NLS
OPTIONS_DEFAULT= CDPARANOIA VORBIS
.if !defined(PACKAGE_BUILDING)
@@ -45,7 +45,7 @@ CONFIGURE_ARGS+= --disable-cdpar
.endif
.if ${PORT_OPTIONS:MCDDA2WAV}
-USE_CDRTOOLS= yes
+RUN_DEPENDS+= cdda2wav:${PORTSDIR}/sysutils/cdrtools
.endif
.if ${PORT_OPTIONS:MFAAC}
@@ -64,9 +64,9 @@ RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "