aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gtkpod
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2010-05-28 00:18:14 +0800
committerdanfe <danfe@FreeBSD.org>2010-05-28 00:18:14 +0800
commitba5d25db82deb7eaa3ec3691440c5cb4af912047 (patch)
tree7893377f9074f0de0c847286c46949345b092f1e /audio/gtkpod
parent48415a690755e3a3831a72ee98a2d40e302ba75a (diff)
downloadfreebsd-ports-gnome-ba5d25db82deb7eaa3ec3691440c5cb4af912047.tar.gz
freebsd-ports-gnome-ba5d25db82deb7eaa3ec3691440c5cb4af912047.tar.zst
freebsd-ports-gnome-ba5d25db82deb7eaa3ec3691440c5cb4af912047.zip
- Fix the build against libmp4v2.so (it is built without GTK support by
default, which will result in HAVE_GTK macro be undefined, and gtkpod depends on it [*] - Correctly detect and record FAAC/FAAD runtime dependencies - Slightly improve on comment while here PR: ports/122639 [*] Submitted by: Kevin Oberman
Diffstat (limited to 'audio/gtkpod')
-rw-r--r--audio/gtkpod/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index 076ae08d4e99..fd83d30842ea 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -42,8 +42,15 @@ OPTIONS= MPEG4IP "Enable AAC and H.264 support with MPEG4IP" off \
.if defined(WITH_MPEG4IP) || exists(${LOCALBASE}/lib/libmp4v2.so)
LIB_DEPENDS+= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
-RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac faad:${PORTSDIR}/audio/faad
+# Define HAVE_GTK to unbreak the build with libmp4v2.so (it is built
+# without Gtk support by default, which can result in gtkpod breakage)
+MAKE_ARGS+= CPPFLAGS="-DHAVE_GTK"
.endif
+.for x in faac faad
+. if exists(${LOCALBASE}/bin/${x})
+RUN_DEPENDS+= ${x}:${PORTSDIR}/audio/${x}
+. endif
+.endfor
.if defined(WITH_VORBIS) || exists(${LOCALBASE}/lib/libvorbis.so)
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
@@ -71,7 +78,7 @@ LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
.endif
pre-configure: .SILENT
-# install locale correctly (share dir instead of lib dir)
+# Install locale files correctly (to share dir instead of lib dir)
${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
${WRKSRC}/configure